Duramax Fuel Guage Pegged - Reply to Topic

Reply to Thread

Post a reply to the thread: Duramax Fuel Guage Pegged

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 06-10-2010, 09:35 PM
    JakeC.
    Quote Originally Posted by Luvnlife View Post
    Took the truck in and the paperwork says that it failed the guage sweep, so they installed the new cluster. Wife says it's working fine. Thanks for the help Jake.
    no problem, anytime you have any d-max questions feel free to ask. its what i do
  • 06-10-2010, 04:04 AM
    Luvnlife
    Took the truck in and the paperwork says that it failed the guage sweep, so they installed the new cluster. Wife says it's working fine. Thanks for the help Jake.
  • 06-05-2010, 03:15 PM
    JakeC.
    Quote Originally Posted by Luvnlife View Post
    It's Power in Valencia. I've always had pretty good luck with them.
    cool deal. i know a couple of the tech's down there. the trans tech there is a good friend and a really good tech.
  • 06-05-2010, 03:01 PM
    Luvnlife
    It's Power in Valencia. I've always had pretty good luck with them.
  • 06-05-2010, 01:09 PM
    JakeC.
    cool deal glad to hear they are takin care of you. what dealer is it?
  • 06-05-2010, 10:27 AM
    Luvnlife
    Just like Jake said. I stopped by the dealer and they wrote it up. Seven years or 70,000 miles. I fit right in as the truck has 69916 when they wrote it up and I bought it June 28 so I just made it. They ordered the cluster and it gets installed Wednesday. Thanks again and I'll update this after the appointment.
  • 06-02-2010, 07:23 PM
    NiceGuyEddie
    My 07 stuck at 35mph a few months back. I disconnected the battery, let it sit for a few and it fixed itself. Great way to avoid the dealer. I take it your 04 is out of warranty.
  • 06-02-2010, 04:45 PM
    bp298
    coming back from sitc last year, the speedo in my '05 started going nuts, and it has over 80k. dealer didn't have to, but replaced it for labor cost. they know those clusters go bad for no reason... talk to your local dealer...
  • 06-02-2010, 04:43 AM
    Luvnlife
    Thanks Jake. I'll def check into it
  • 06-01-2010, 09:32 PM
    JakeC.
    just checked on the special policy. there is one that applies to your truck. it is for 2003-2004 trucks/subs/tahoes ...ect. it covers the clusters for the same problem you are having for 7 years or 70,000 miles. its gm Document ID: 2253005. i would call gm tomarrow to see if they will help you out.
  • 06-01-2010, 09:26 PM
    JakeC.
    you can call gm they may still cover your cluster. there is a special policy on them, im not sure what years it covers and for how long though.
  • 06-01-2010, 07:38 PM
    Luvnlife
    Quote Originally Posted by eliminator cat View Post
    Had the same thing happen to mine, very common issue. I called GM and was able to get mine covered because i had less than 50k miles. Fuel gauge went then oil pressure next.
    Mine has 70k, gee I guess I have to watch that one also
  • 06-01-2010, 07:37 PM
    Luvnlife
    Quote Originally Posted by JakeC. View Post
    yea the gauge itself. work at a dealer so i can try and find out who repairs them. dont know off the top of my head.
    That would be great. Let me know
  • 06-01-2010, 07:05 PM
    eliminator cat

    Duramax dash issue

    Quote Originally Posted by Luvnlife View Post
    I filled up my wifes 04 Duramax late last week, today I get in and start it up and the fuel guage is pegged. More than the full mark it is way past. The truck has been driven and it shouldn't be at the full mark. Anyone ever have this problem or any hints were to start tracking it down. Thanks
    Had the same thing happen to mine, very common issue. I called GM and was able to get mine covered because i had less than 50k miles. Fuel gauge went then oil pressure next.
This thread has more than 14 replies. Click here to review the whole thread.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93