The Hunt goes deeper...
+ Reply to Thread
Page 1 of 6 1 2 3 4 ... LastLast
Results 1 to 14 of 82

Thread:
The Hunt goes deeper...

  1. #1
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Exclamation The Hunt goes deeper...

    Trying to find the reason oil pressure dropped when punching the throttle from 3000-5200 rpm. This just started happening towards the end of the season...no knocks/taps etc engine ran great. And no, oil level was not over full and mechcnical gauge was replaced for the test.

    After pulling the Milidon 10/qt pan and the HV oil pump I had hoped to see maybe a cracked/dropped oil pickup or stuck trap-doors or even the violet oil pump spring cracked or bypass plunger stuck...nope smooth as silk.
    Next, main and rod caps.

    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member NiceGuyEddie's Avatar
    Join Date
    Dec 2007
    Location
    Anaheim Hills
    Posts
    5,838

    Default

    I found my Miloden Oil pick up lying in the bottom of my pan. It broke right where its silver sodered on the pick up tube.

    It caused severe damage. Lets say I didn't hope to see that.

  4. #3
    Senior Member
    Join Date
    Dec 2008
    Posts
    179

    Default oil ##

    how much oil pressure? after it was hot? how much did the motor used to run? dont forget to check cam bearings. hope you dont you will find some rod/main bearings going south,
    10 psi for every 1000 rpm
    good luck but sounds like you new when to shut it off. so you are smarter then me.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    steelcomp was here
    Join Date
    Dec 2007
    Location
    n/e TN
    Posts
    26,507

    Default

    Did you by any chance change oil filters?
    If God is your co-pilot, change seats!
    Acts 2:38, the perfect answer to the perfect question.

  7. #5
    LP-25.com Infomaniac's Avatar
    Join Date
    Dec 2007
    Location
    New Port Richey, FL
    Posts
    16,872

    Default

    What external to the engine devices are installed? And what size hose is used? How many 90* fittings etc.

  8. #6
    gn7
    gn7 is offline
    Senior Member gn7's Avatar
    Join Date
    Jan 2008
    Posts
    25,975

    Default

    Quote Originally Posted by HammerDown View Post
    Trying to find the reason oil pressure dropped when punching the throttle from 3000-5200 rpm. This just started happening towards the end of the season...no knocks/taps etc engine ran great.
    Like Steel asked, did you change filter brands, and did you change oil brands



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
    Last edited by gn7; 12-31-2008 at 07:35 AM.

  9. #7
    steelcomp was here
    Join Date
    Dec 2007
    Location
    n/e TN
    Posts
    26,507

    Default

    Quote Originally Posted by gn7 View Post
    Like Steel asked, did you change filter brands, and did you change brands
    Huh?
    Little early?
    If God is your co-pilot, change seats!
    Acts 2:38, the perfect answer to the perfect question.

  10. #8
    gn7
    gn7 is offline
    Senior Member gn7's Avatar
    Join Date
    Jan 2008
    Posts
    25,975

    Default

    that's what I get for reading a couple of ole guys posts this early in the morning. Hell it took me 5 minutes to figure out what you were talking about! I am fine now, two more cups of coffee. Thanks Steel, I needed that.



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

  11. #9
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Default

    I'll attempt to answer in order of questions asked...

    *Oil pressure "hot" and cruising/3200 rpm was 65/75psi and when punching it to 5200 would rapidly drop some 15/20 lbs. This just started happening as of late last season.

    *I always used Purolator L20049 and did change it to see if that was a possible cause...nope.

    *No external engine devices, oil cooler/remote filter etc.

    *Oil Brands, Valvoline RV1 Racing HOWEVER early last season I switched from straight 50wt to 20/50. As a last test I put 50wt back in, all around pressure was better but it still dropped when stabbing the pedal. Let off throttle, pressure would again climb. Also, if I slowly raised RPM pressure would not drop. I don't recall ever unloading pump/engine to grab a bearing.

    *I did cut filter open and saw nothing...also, the bottom of the pan was very clean, some very slight black after finger swipe, my guess carbon dust.

    Pulling bearing caps today.
    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

  12. #10
    steelcomp was here
    Join Date
    Dec 2007
    Location
    n/e TN
    Posts
    26,507

    Default

    Well, if this was a sudden change from the norm, then I think it's safe to say something has changed. Otherwise, it just sounds like poor oil control in the pan, oil evacuating the pickup and/or aeration of the oil under sudden acceleration. Sure you just didn't notice it before?
    If God is your co-pilot, change seats!
    Acts 2:38, the perfect answer to the perfect question.

  13. #11
    steelcomp was here
    Join Date
    Dec 2007
    Location
    n/e TN
    Posts
    26,507

    Default

    Quote Originally Posted by gn7 View Post
    that's what I get for reading a couple of ole guys posts this early in the morning. Hell it took me 5 minutes to figure out what you were talking about! I am fine now, two more cups of coffee. Thanks Steel, I needed that.
    Always glad to be a pain in the a....I mean help.
    If God is your co-pilot, change seats!
    Acts 2:38, the perfect answer to the perfect question.

  14. #12
    Senior Member 4CE FED's Avatar
    Join Date
    May 2008
    Posts
    320

    Talking

    I'll sell you some known good oil out of my engine. It read 60 psi @WOT.
    sorry couldn't resist....

  15. #13
    TEN THIRTY ONE RCB19's Avatar
    Join Date
    Dec 2007
    Posts
    1,293

    Default

    Quote Originally Posted by steelcomp View Post
    W Otherwise, it just sounds like poor oil control in the pan, oil evacuating the pickup and/or aeration of the oil under sudden acceleration.
    That would be it. Oil control in those pans is horrible. Chased the same problem on a motor years ago and never solved it till I ditched the Milodon.

    This would be a nice direction to take.

    http://www.performanceboats.com//showthread.php?t=26097
    RCB

  16. #14
    Lurker
    Join Date
    Dec 2007
    Location
    NC
    Posts
    1,417

    Default

    Quote Originally Posted by RCB19 View Post
    This would be a nice direction to take.

    http://www.performanceboats.com//showthread.php?t=26097
    Yes it would!!!

    Pick up some power and get all the oil control you'll ever need. And hey, you already have a top mounted starter.....Perfect!

    Great deal on that pan too!

+ Reply to Thread
Page 1 of 6 1 2 3 4 ... LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95