[Pics] water intake hose came off 460
+ Reply to Thread
Results 1 to 6 of 6

Thread:
water intake hose came off 460

  1. #1
    Member 07liberator's Avatar
    Join Date
    May 2012
    Location
    Monroe, Ohio, United States
    Posts
    43

    Default water intake hose came off 460

    Well Im breaking in my 07 liberator 21 tunnel 460 motor built a little 430 or so hp, dom pump, when the water intake hose came off and hull flooded a little over my fuel pump.So then i noticed the water on the carpet and then looked at water temp guage it was pegged,I shut it down then put the hose back on and pumped water out of the hull,now it would start back up but only on a few pistons and my oil preasure guage does not move.....any help please
    Attached Images Attached Images  

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member
    Join Date
    Dec 2007
    Location
    corona calif
    Posts
    1,119

    Default 460 Ford

    Quote Originally Posted by 07liberator View Post
    Well Im breaking in my 07 liberator 21 tunnel 460 motor built a little 430 or so hp, dom pump, when the water intake hose came off and hull flooded a little over my fuel pump.So then i noticed the water on the carpet and then looked at water temp guage it was pegged,I shut it down then put the hose back on and pumped water out of the hull,now it would start back up but only on a few pistons and my oil preasure guage does not move.....any help please
    Do you have any idea how long you ran it like this. 1 minute or 5 minutes?

  4. #3
    Member 07liberator's Avatar
    Join Date
    May 2012
    Location
    Monroe, Ohio, United States
    Posts
    43

    Default water intake hose 460

    Well Greg it was under 5 min,I think water got in the fuel pump and for the oil preasure its an electric guage but any how Im hoping its all due to getting wet,Ill find out Thursday sometime,Ill keep ya posted thanks.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member
    Join Date
    Aug 2010
    Posts
    836

    Default

    both water temp and oil pressure electrical gauges will read pegged when grounded. i suspect that you got moisture in them and thus they're grounding/shorted and thats why you're getting a pegged gauge. good thing is that they're pretty cheap to replace. you can easily test them by just removing the signal wire from the sender and you should see the gauge needle go to 0.
    Last edited by ka0tyk; 05-30-2012 at 05:40 PM.

  7. #5
    Member 07liberator's Avatar
    Join Date
    May 2012
    Location
    Monroe, Ohio, United States
    Posts
    43

    Default water intake hose 460

    Well Greg it was under 5 min,I think water got in the fuel pump and for the oil preasure its an electric guage but any how Im hoping its all due to getting wet,Ill find out Thursday sometime,Ill keep ya posted thanks.

  8. #6
    Member 07liberator's Avatar
    Join Date
    May 2012
    Location
    Monroe, Ohio, United States
    Posts
    43

    Default

    Well got news on the 460 today,seems all 8 are fireing that problem we think was do to water but the oil pump shaft is broken on the (new elgin pump) whats up with that??,got to pull motor and have them look to see if anything else has been damaged////
    Quote Originally Posted by 07liberator View Post
    Well Greg it was under 5 min,I think water got in the fuel pump and for the oil preasure its an electric guage but any how Im hoping its all due to getting wet,Ill find out Thursday sometime,Ill keep ya posted thanks.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95