jet problems
+ Reply to Thread
Results 1 to 4 of 4

Thread:
jet problems

  1. #1
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Default jet problems

    I dont know if I have a serious problem or not, the last time I took my boat out it was going fine then all of a sudden we couldn't go any faster then idle. Tried to give it gas and it would vibrate real bad. Took it out of the water and nothing to be found clogging the jet. Could I have frooze a bearing?

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member
    Join Date
    Dec 2007
    Location
    corona calif
    Posts
    1,119

    Default

    Quote Originally Posted by CJTCommander View Post
    I dont know if I have a serious problem or not, the last time I took my boat out it was going fine then all of a sudden we couldn't go any faster then idle. Tried to give it gas and it would vibrate real bad. Took it out of the water and nothing to be found clogging the jet. Could I have frooze a bearing?
    I would think that if the bearing was bad that it would not idle because the bearing is starting to sieze. I beleive you either have something in the pump that you cannot see or when you took it out of the water it fell out. Are you running a loader grate? Remember a very small piece of anything will cause the pump to cavatate.

  4. #3
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Default

    Quote Originally Posted by greg shoemaker View Post
    I would think that if the bearing was bad that it would not idle because the bearing is starting to sieze. I beleive you either have something in the pump that you cannot see or when you took it out of the water it fell out. Are you running a loader grate? Remember a very small piece of anything will cause the pump to cavatate.
    Thanks, I try it out next week

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Member
    Join Date
    Mar 2011
    Posts
    36

    Default Pumps shakin'

    Quote Originally Posted by CJTCommander View Post
    I dont know if I have a serious problem or not, the last time I took my boat out it was going fine then all of a sudden we couldn't go any faster then idle. Tried to give it gas and it would vibrate real bad. Took it out of the water and nothing to be found clogging the jet. Could I have frooze a bearing?
    Check to see if a rock or rope got caught in your pump....I sucked a clam one time and had the same results....ok so I'm a clam sucker...but it's fact Good luck

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95