Stainless steel Imp question
+ Reply to Thread
Results 1 to 14 of 14

Thread:
Stainless steel Imp question

  1. #1
    Senior Member rvrskir's Avatar
    Join Date
    Oct 2008
    Location
    Lakewood, CA
    Posts
    284

    Default Stainless steel Imp question

    Should it be this loud at idle with water going thru the pump? :screwy:

    http://s13.photobucket.com/albums/a2...t=IMG_2148.mp4
    Last edited by rvrskir; 05-06-2012 at 05:43 PM.
    1973 Rogers Cyclone- 16' 6"- 350 SBC
    1976 Hondo Pantera- 18'- 455 BBO

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    B1 Racing cs19's Avatar
    Join Date
    Dec 2007
    Posts
    6,523

    Default

    Thats louder than most but its probably just the driveline, does the noise stop once you give it more throttle?
    B1Racing.net

  4. #3
    Senior Member rvrskir's Avatar
    Join Date
    Oct 2008
    Location
    Lakewood, CA
    Posts
    284

    Default

    noise is completely gone when at speed. only happens when idling
    1973 Rogers Cyclone- 16' 6"- 350 SBC
    1976 Hondo Pantera- 18'- 455 BBO

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member pilot940's Avatar
    Join Date
    Mar 2009
    Location
    Chandler, AZ
    Posts
    162

    Default

    I had that noise once. It turned out being the impeller was loose on the shaft. Had got some grease or something on the shaft when installing the impeller, then it washed out and made that noise.

    It also went away when under load.

  7. #5
    B1 Racing cs19's Avatar
    Join Date
    Dec 2007
    Posts
    6,523

    Default

    Since it goes away with some throttle It's likely from the yoke and or pumpshaft splines having some wear on them and at idle the impeller is sorta ratcheting since there is very little load on the spline, once you throttle up it loads the splines and it's all good. Wouldn't hurt to look over the thrust bearing, wear ring, impeller and nut and bowl bushing hardware just to eliminate any other possibilities. The clunking you hear is common that one just seems a bit louder than most.
    B1Racing.net

  8. #6
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Heavy Impellers (Bronze and Stainless) will create or aggravate "machine noise" a low RPM grumbling stacatto clatter or groan from the frt of pump rear of engine area sometimes heard thruout the hull ,this noise is worse with when theres a bit of pump shaft spline or drive line female spline wear or looseness Or a combination there-of), as said it should dissipate with slight load on the impeller (above idle) Tom

  9. #7
    Senior Member rvrskir's Avatar
    Join Date
    Oct 2008
    Location
    Lakewood, CA
    Posts
    284

    Default

    Thanks for the input guys!
    Tom I wish you were closer to me i would bring it by for you to check out.
    Anyone know of a good jet boat shop close to the Long Beach area?
    1973 Rogers Cyclone- 16' 6"- 350 SBC
    1976 Hondo Pantera- 18'- 455 BBO

  10. #8
    Senior Member
    Join Date
    Apr 2010
    Location
    Rocklin, Calif.
    Posts
    1,396

    Default

    Quote Originally Posted by rvrskir View Post
    Thanks for the input guys!
    Tom I wish you were closer to me i would bring it by for you to check out.
    Anyone know of a good jet boat shop close to the Long Beach area?
    Sounds to me like you spun the isolater out and under power you've got water for lube
    Tom, what do you think?

  11. #9
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Quote Originally Posted by rvrskir View Post
    Thanks for the input guys!
    Tom I wish you were closer to me i would bring it by for you to check out.
    Anyone know of a good jet boat shop close to the Long Beach area?
    Honored to be considered !
    Quote Originally Posted by Gone Green View Post
    Sounds to me like you spun the isolater out and under power you've got water for lube
    Tom, what do you think?
    Could be ...., easy to check , Rvr what GG's refering to is that the possibility exists the the insulator between the wear ring and suction housing could have become dislodged (for lack of a better term) allowing the wear ring to rattle around inside the jet pull the cleanout and take a good look at what you can see of the wear ring, call if we can help Tom

  12. #10
    Senior Member rvrskir's Avatar
    Join Date
    Oct 2008
    Location
    Lakewood, CA
    Posts
    284

    Default

    hmm seems like an easy check. if it is this what needs to be done to get it back in place?
    1973 Rogers Cyclone- 16' 6"- 350 SBC
    1976 Hondo Pantera- 18'- 455 BBO

  13. #11
    About 500' AGL MudPumper's Avatar
    Join Date
    Jan 2008
    Location
    Santa Clarita
    Posts
    2,470

    Default

    Quote Originally Posted by rvrskir View Post
    Anyone know of a good jet boat shop close to the Long Beach area?
    Go see CS19 (Chris) at B1racing in Costa Mesa.

    www.B1racing.net
    Last edited by MudPumper; 05-07-2012 at 01:55 AM.

  14. #12
    Senior Member
    Join Date
    Dec 2007
    Posts
    995

    Default

    Quote Originally Posted by rvrskir View Post
    hmm seems like an easy check. if it is this what needs to be done to get it back in place?
    Bowl will have to come off and impeller removed.

  15. #13
    Senior Member rvrskir's Avatar
    Join Date
    Oct 2008
    Location
    Lakewood, CA
    Posts
    284

    Default

    Thanks for the help guys. Took it over to MPD who said he saw nothing wrong in the jet. Impeller has some nicks but not bad. Ujoints were a little loose... Guess i will run it all summer then next winter have the whole jet gone thru
    1973 Rogers Cyclone- 16' 6"- 350 SBC
    1976 Hondo Pantera- 18'- 455 BBO

  16. #14
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Default

    Quote Originally Posted by rvrskir View Post
    Thanks for the help guys. Took it over to MPD who said he saw nothing wrong in the jet. Impeller has some nicks but not bad. Ujoints were a little loose... Guess i will run it all summer then next winter have the whole jet gone thru
    I wouldn't...that vibration travels directly to the crankshaft.
    And I'm sure the pumps thrust bearing wouldn't like it much either.
    Handle it now for a worry-free season vs maybe having to deal with it mid summer.
    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95