Got my Pyle back on the water
+ Reply to Thread
Results 1 to 8 of 8

Thread:
Got my Pyle back on the water

  1. #1
    Senior Member cave's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    4,704

    Default Got my Pyle back on the water

    My winter project is done


    Click image for larger version. 

Name:	538652_3963920067681_1833860078_n.jpg 
Views:	70 
Size:	25.3 KB 
ID:	222330

    Click image for larger version. 

Name:	734087_4106399469577_285363462_n.jpg 
Views:	69 
Size:	28.3 KB 
ID:	222322

    Pump got some love too. THX Tony Skagen for the Inducer
    Special Thanks to Brian Bergeron of Bergeron Engineering. Brian cut the shaft replaced the bearing and got it to me in just an hour. Great Local service!
    Click image for larger version. 

Name:	182320_3835211370044_685091529_n.jpg 
Views:	64 
Size:	18.6 KB 
ID:	222338

    Click image for larger version. 

Name:	302815_3835211610050_1345014039_n.jpg 
Views:	67 
Size:	12.9 KB 
ID:	222346

    The end result of all of this,

    Click image for larger version. 

Name:	223538_4237473546347_989105134_n.jpg 
Views:	83 
Size:	21.5 KB 
ID:	222354
    Last edited by cave; 02-18-2013 at 05:50 AM.
    Takin it home

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member ICECREAMAN's Avatar
    Join Date
    May 2009
    Posts
    2,426

    Default

    Sounds nice, looks nice too! So, maybe I missed it, but what happened to the motor? I know you've had it apart a couple times, did you exercise the Gremlins?

  4. #3
    Senior Member cave's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    4,704

    Default

    I sheared the 3 cam gear bolts last July 3rd. I imagine the 3 bolts were over torqued. Gen 5 and 6 do not offer a cam bolt retention plate. I made one for this build. Bent the tabs against the bolts and added red loctight too. A bit of overkill. When this happened it took out 1 valve stem and of coarse the main bearings and cam bearings too. I replaced all the bearings, rods too. Had the crank inspected & ground down a bit along with the caps being repaired and then line honed. Just in case. Picked up a tad bit more aggressive cam. Added the HM inducer. Dam it pulls hard. and that's what I was trying to get back. I may not go fast but the boat pulls you back into the buckets hard! Plains instantly. The boats fun to drive again.

    I had to wait on the stud girdle bolts. But finally got it all back together. I just ordered an MSD starter saver. I'm locked out at 30° The boats is hard to start. I'm hoping the MSD part will work. Other than that My winter refurbish is done.

    I believe 460 picked up your inducer right? He may be installing it in a few weeks.
    Takin it home

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member zacho!'s Avatar
    Join Date
    Jun 2009
    Location
    tucson, Arizona
    Posts
    979

    Default

    Quote Originally Posted by cave View Post
    I sheared the 3 cam gear bolts last July 3rd. I imagine the 3 bolts were over torqued. Gen 5 and 6 do not offer a cam bolt retention plate. I made one for this build. Bent the tabs against the bolts and added red loctight too. A bit of overkill. When this happened it took out 1 valve stem and of coarse the main bearings and cam bearings too. I replaced all the bearings, rods too. Had the crank inspected & ground down a bit along with the caps being repaired and then line honed. Just in case. Picked up a tad bit more aggressive cam. Added the HM inducer. Dam it pulls hard. and that's what I was trying to get back. I may not go fast but the boat pulls you back into the buckets hard! Plains instantly. The boats fun to drive again.

    I had to wait on the stud girdle bolts. But finally got it all back together. I just ordered an MSD starter saver. I'm locked out at 30° The boats is hard to start. I'm hoping the MSD part will work. Other than that My winter refurbish is done.

    I believe 460 picked up your inducer right? He may be installing it in a few weeks.
    So good Cave! One of these years Ill be out there with ya!!

  7. #5
    Senior Member ICECREAMAN's Avatar
    Join Date
    May 2009
    Posts
    2,426

    Default

    Quote Originally Posted by cave View Post
    I sheared the 3 cam gear bolts last July 3rd. I imagine the 3 bolts were over torqued. Gen 5 and 6 do not offer a cam bolt retention plate. I made one for this build. Bent the tabs against the bolts and added red loctight too. A bit of overkill. When this happened it took out 1 valve stem and of coarse the main bearings and cam bearings too. I replaced all the bearings, rods too. Had the crank inspected & ground down a bit along with the caps being repaired and then line honed. Just in case. Picked up a tad bit more aggressive cam. Added the HM inducer. Dam it pulls hard. and that's what I was trying to get back. I may not go fast but the boat pulls you back into the buckets hard! Plains instantly. The boats fun to drive again.

    I had to wait on the stud girdle bolts. But finally got it all back together. I just ordered an MSD starter saver. I'm locked out at 30° The boats is hard to start. I'm hoping the MSD part will work. Other than that My winter refurbish is done.

    I believe 460 picked up your inducer right? He may be installing it in a few weeks.
    No, not me. We talked a little about inducers when you were looking at buying one. Glad to hear alls good now. Funny, my motor is locked @ 30* also with a mini starter and so far it cranks like a champ. But my battery cable is less than 3' to the starter, and my wiring is as short as possible.

  8. #6
    Senior Member cave's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    4,704

    Default

    Mine used to start up fine too. Maybe the new cam is making it an issue. I pondered adding a Ford relay. Maybe not. we'll see how it goes.

    Feels good to be driving a boat again!
    Takin it home

  9. #7
    "BOATLESS" blender over's Avatar
    Join Date
    Jan 2008
    Location
    Wildomar/Big River/OcotilloWells
    Posts
    3,468

    Default

    Tyro bought my old inducer, it was a DPS, nice piece, hope it works well for him.

  10. #8
    Senior Member Tony Skagen's Avatar
    Join Date
    Jan 2008
    Posts
    539

    Default

    Nice job!!!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95