Jacuzzi wj pump shaft question
+ Reply to Thread
Results 1 to 4 of 4

Thread:
Jacuzzi wj pump shaft question

  1. #1
    Senior Member crf311's Avatar
    Join Date
    Mar 2008
    Location
    Meraux, LA
    Posts
    357

    Default Jacuzzi wj pump shaft question

    Hey guys I have a question about the feel I get when I twist the shaft on my Jacuzzi Wj pump. I had to pull the motor to find a oil leak and while it was out I wanted to feel how easily my pump shaft spun. If spun freely, but when I kind of twisted it back and forth it felt like there was a looseness between the shaft and the impeller. Almost like what you would feel setting the gear mesh on the rear end of a car. Should this be happening or should I pull the pump apart and make sure the nut and keyway are tight? Thanks.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member Mash on It's Avatar
    Join Date
    Mar 2008
    Location
    Willow Beach & BHC
    Posts
    170

    Default WJ nut

    Sounds like the nut loose/keyway wear. or was this on the splines of the drive shaft? Or wear ring missing screws? sounds like time to pull the bowl, at least........ Daniel
    "Never mind the mule, Just load the wagon"
    '76 Eliminator 21'

  4. #3
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Quote Originally Posted by crf311 View Post
    Hey guys I have a question about the feel I get when I twist the shaft on my Jacuzzi Wj pump. I had to pull the motor to find a oil leak and while it was out I wanted to feel how easily my pump shaft spun. If spun freely, but when I kind of twisted it back and forth it felt like there was a looseness between the shaft and the impeller. Almost like what you would feel setting the gear mesh on the rear end of a car. Should this be happening or should I pull the pump apart and make sure the nut and keyway are tight? Thanks.
    OEM Wjs have a taper fit on impeller/to pump shaft connection , It would be rather unusual for any slack or "play" , if you can rock the shaft back and forth by hand? would suggest a loose or damaged impeller among other conditions Tom

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member crf311's Avatar
    Join Date
    Mar 2008
    Location
    Meraux, LA
    Posts
    357

    Default

    Thanks guys. I'll have to pull it down and see what's going on in there.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95