Jacuzzi wj-12
+ Reply to Thread
Results 1 to 6 of 6

Thread:
Jacuzzi wj-12

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Posts
    28

    Default Jacuzzi wj-12

    I have a 12 wj and the shaft was seized up took it apart and the plastic wear ring was cracked and broke in a few places could this cause the shaft to seize? ? This is my first jet boat so im new to all this.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    We're you running and the pump seized? Or did you pull the bowl and wouldn't spin?

    The impeller is keyed on the shaft. if a piece of the WR is obstructing the impeller it won't spin the shaft. If the impeller spins but shaft does not that's a bigger issue.

    Now that I think about it, you have to pull the impeller to access the WR, so with no impeller on there the shaft doesn't turn? Is the motor still connected?


    Sent from my iPhone using Tapatalk 2
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  4. #3
    Junior Member
    Join Date
    Jul 2013
    Posts
    28

    Default

    No motor is out of the boat the bearing in frong of the shaft was also seized up the last guy neglected it the wear ring is plastic correct? ? I even put a pipe wrench on it and still wouldn't move when I pulled it the impeller waz at the very back of the pump looks like it was hitting the back part it broke the screws off that hold the plastic piece on

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    Sounds like the thrust bearing let go, impeller/ shaft move forward, impeller starts eating the bowl/WR.

    Pics would help.

    Tear it all down and go over everything.

    Give Tom at Jet Boat Performance a ring he can get you all set up.




    Sent from my iPhone using Tapatalk 2
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  7. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    921

    Default wj

    Quote Originally Posted by 72Hondo View Post
    Sounds like the thrust bearing let go, impeller/ shaft move forward, impeller starts eating the bowl/WR.

    Pics would help.

    Tear it all down and go over everything.

    Give Tom at Jet Boat Performance a ring he can get you all set up.




    Sent from my iPhone using Tapatalk 2
    I have a 12wj used pump looks to be in good running cond $400.00 Jim 1818-890-1867

  8. #6
    Junior Member
    Join Date
    Jul 2013
    Posts
    28

    Default

    This is what I found and the bearing on the front of the shaft. I think that's what caused it

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95