It Floats and runs. Nordic BBC 8-71 EFI..vid
+ Reply to Thread
Results 1 to 6 of 6

Thread:
It Floats and runs. Nordic BBC 8-71 EFI..vid

  1. #1
    TJS
    TJS is offline
    Senior Member
    Join Date
    Jan 2008
    Location
    CT
    Posts
    269

    Default It Floats and runs. Nordic BBC 8-71 EFI..vid

    Got it wet and just took it easy on the lake. Still have some tuning to do with a wide band. Here is a video of just crusing along.


    This next video is at the sandbar (Lake Zoar in CT.) Notice the cops going real slow with their strobes on. They passed about 30 boats with open alcohol containers (CT. state law). Then the dude in the smoke stack Placecraft next to me has to tell the cop about his hooptie exhaust he so called cobbled up cause he got busted for speeding and I guess load exh.
    Did I say the cops hate Jet boats on this lake.


    T.J.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member GRoper's Avatar
    Join Date
    Jun 2009
    Posts
    2,021

    Default

    looks nice!!!

  4. #3
    Highaboosta Unchained's Avatar
    Join Date
    Dec 2007
    Location
    Ada, Michigan
    Posts
    3,431

    Thumbs up

    Great job.
    I like the polished alum splashguard.

    I bet you have a good handle on the EFI tuning now.

    Twin Turbo 1800 HP V-Drive lake boat

    http://s621.photobucket.com/albums/t...t=MAH05771.mp4

    Quote Originally Posted by Trigger View Post
    No one cares about your buddies old antiquated garden hose technology.
    Quote Originally Posted by MAXIMUS View Post
    I think I could run more boost but it's a real hand full right now

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Wet
    Wet is offline
    Banned
    Join Date
    Dec 2007
    Location
    East Hampton, CT
    Posts
    4,957

    Default

    Looking and sounding great T.J.

  7. #5
    TJS
    TJS is offline
    Senior Member
    Join Date
    Jan 2008
    Location
    CT
    Posts
    269

    Default

    Got some more tuning done this eve with a well known tuner on the east coast. It idles rock solid at 1000 RPMs and starts right up with a touch of the key. Will be making some more runs this weekend. Don't panic it is not lean in the picture. The wide band was off cause we were done. I shut the main battery switch off and it lost its signal to the laptop.
    T.J.


  8. #6
    Senior Member MACHINEHEAD1's Avatar
    Join Date
    May 2008
    Posts
    473

    Default

    Small lap top is still online to ECU. Are you running wide band to the other lap top as a data log only. See if your tuner has a GEN 7+ pro key. Then you can run all data to 1 lap top with your Thruster. Only 1 lap top to get wet!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95