Pump Problems
+ Reply to Thread
Results 1 to 12 of 12

Thread:
Pump Problems

  1. #1
    6th Street Mafia PrecisionTile's Avatar
    Join Date
    Mar 2009
    Location
    Corona, CA
    Posts
    164

    Default Pump Problems

    I took these pictures earlier this year and I figured I would post them to see if my theory was correct on what might have happened. My theory is that I sucked something into the pump that dinged the impeller and caused it to be out of balance which in turn caused the end of the pump shaft to be worn heavily on the one side. I might be wrong but this is what I think happened. Any other input would be greatly appreciated. Since this was taken I have replaced the shaft, impeller, wear ring, bearing, and bushings. I had it all together but I learned the hard way that you can set a pump up too tight, I set it up a .005" and it ran perfect on the trailer but as soon as I put it in the water the impeller hit the wear ring and locked up.







    SOCIALISM: Tax Dollars At Work For People Who Don't

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Default

    Ha, been there done that...ONCE...12 years ago!
    I too set my pump up a .005 one time. Didn't realize how much the impeller (aluminum) moves/expands when loaded. Also, my new thrust ZKL bearing was bad. I tested it on a simple arm press with nothing but arm weight pulling down. Sucker had over .030 movement! .005 - .030 = lock-up real fast.
    At that time Tom Papp (great guy) had me send back my f'ed up Aggressor imp wear ring, and thrust bearing where he also tested and found to be bad. Sent me everything new and said .018 was a good number to use at the impeller, been there ever since, >sure miss chatting with Tom though.
    Note...when running a snug clearance check runout on the shaft and ALWAYS zero out the impeller on the shaft, on a lathe.
    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

  4. #3
    6th Street Mafia PrecisionTile's Avatar
    Join Date
    Mar 2009
    Location
    Corona, CA
    Posts
    164

    Default

    X2 on missing Tom, he helped me set up my pump three years ago. At that time I think I set it up at .020" and it raun for three years until I sucked something into it. I have been told to set it up at around .030"


    SOCIALISM: Tax Dollars At Work For People Who Don't

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    B1 Racing cs19's Avatar
    Join Date
    Dec 2007
    Posts
    6,523

    Default

    That ding on the trailing edge did not cause the wear on the shaft.
    B1Racing.net

  7. #5
    Senior Member GT Jets's Avatar
    Join Date
    Jun 2008
    Location
    Morgan Hill
    Posts
    2,234

    Default

    Quote Originally Posted by cs19 View Post
    That ding on the trailing edge did not cause the wear on the shaft.

    X2, that shaft is bent....or twisted...

    GT
    GT


    Quote Originally Posted by Quickjet View Post
    Put a 300 on the back of it, Flywheel it and a nosecone. $15,000 later you'll have a 65 mph pile of shit......

  8. #6
    6th Street Mafia PrecisionTile's Avatar
    Join Date
    Mar 2009
    Location
    Corona, CA
    Posts
    164

    Default

    What would have bent the shaft? Could the impact of whatever hit the impeller have bent the shaft?


    SOCIALISM: Tax Dollars At Work For People Who Don't

  9. #7
    B1 Racing cs19's Avatar
    Join Date
    Dec 2007
    Posts
    6,523

    Default

    Its not necassarily bent, my guess is its not bent and could be re hard chromed and used again. That area on the shaft could have worn like that for many reasons. Were the bushings in the bowl spun out or worn real bad?
    B1Racing.net

  10. #8
    DJD
    DJD is offline
    6TH STREET MAFIA PRES. DJD's Avatar
    Join Date
    Jan 2008
    Location
    Closer to the river than you!
    Posts
    1,493

    Default

    I had a shaft that was worn similar to that but not near as bad as that one. We checked the ballance on the assy and it was a mile off so when i freshened up the pump and installed all new parts i had Dugans spin ballance the assy. i saw an impeller that looked like that a while back but it was hooked up to decent hp and was being beat on loading and unloading under power. Probably not your problem just throwing that out there. Good luck.

  11. #9
    Senior Member GT Jets's Avatar
    Join Date
    Jun 2008
    Location
    Morgan Hill
    Posts
    2,234

    Default

    Quote Originally Posted by PrecisionTile View Post
    What would have bent the shaft? Could the impact of whatever hit the impeller have bent the shaft?
    I have a shaft in the drawer of shame that has a 15* twist with a slight corcscrew shape to it, not saying that is exactly what you heve there, but it does happen, I was referring to the heavy wear on the one side of the end....a bent shaft will cause ginourmous out of balance...

    I always etch the shaft on the ends and middle when using stockers to index it for straight, you will normally see a twist at the splines...

    GT
    GT


    Quote Originally Posted by Quickjet View Post
    Put a 300 on the back of it, Flywheel it and a nosecone. $15,000 later you'll have a 65 mph pile of shit......

  12. #10
    6th Street Mafia PrecisionTile's Avatar
    Join Date
    Mar 2009
    Location
    Corona, CA
    Posts
    164

    Default

    The bowl bushings were in good shape. Thanks for the input guys, DJD are you going out for Labor Day.


    SOCIALISM: Tax Dollars At Work For People Who Don't

  13. #11
    DJD
    DJD is offline
    6TH STREET MAFIA PRES. DJD's Avatar
    Join Date
    Jan 2008
    Location
    Closer to the river than you!
    Posts
    1,493

    Default

    Quote Originally Posted by PrecisionTile View Post
    The bowl bushings were in good shape. Thanks for the input guys, DJD are you going out for Labor Day.
    Ya we are headin out thursday afternoon and staying till monday. What about you guys? I think we are staying at hidden beaches.

  14. #12
    6th Street Mafia PrecisionTile's Avatar
    Join Date
    Mar 2009
    Location
    Corona, CA
    Posts
    164

    Default

    I have to drop off my impeller at GS to be cut down one last time. I should be out there on Sat. Morning. I think we are going to stay back in town.


    SOCIALISM: Tax Dollars At Work For People Who Don't

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95