What happened??
+ Reply to Thread
Results 1 to 9 of 9

Thread:
What happened??

  1. #1
    Senior Member CK7684's Avatar
    Join Date
    Aug 2008
    Location
    Minnesota
    Posts
    550

    Default What happened??

    Boat is running awesome now (engine-wise) but over the weekend I got a rumbling noise. After taking a look there is what looks to be an O-ring that came out along with a lot of grease from the front of the pump, underneath where the front grease zerk is. The pump is a Berk "F" model...

    Any ideas??

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    Quote Originally Posted by CK7684 View Post
    Boat is running awesome now (engine-wise) but over the weekend I got a rumbling noise. After taking a look there is what looks to be an O-ring that came out along with a lot of grease from the front of the pump, underneath where the front grease zerk is. The pump is a Berk "F" model...

    Any ideas??

    That sounds like your main bearing seal.. Dont run your stuff... If that bearing was eaten up you need to replace it or risk serious damage...


    Did the seal pop out of that center peice right in the middle here?





    Mines has a three point mount. Yours may be different.






    This is what is inside there. if that goes at speed you will be replacing that pump and maybe the engine...

    Last edited by Delemorte; 09-09-2009 at 04:12 PM.
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

  4. #3
    Senior Member CK7684's Avatar
    Join Date
    Aug 2008
    Location
    Minnesota
    Posts
    550

    Default

    I tried to take a pic, but they werent turning out very well. All I could see was an O-ring hanging around the shaft, with a bunch of grease underneath where the zerk is. I dont plan on running it again until this is fixed, but I'm wondering what may have caused the problem and what I'm going to need. I was thinking that possibly the driveline adjustment was off, but I have a full bellhousing that goes over the front of the pump, so it seems that it would be difficult to be very far off.
    Also, the pump was rebuilt fall of 2007 and everything ran good all season 2008...this is basically the only weekend I've had it out this year besides when checking my oil pressure issue...

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member CK7684's Avatar
    Join Date
    Aug 2008
    Location
    Minnesota
    Posts
    550

    Default

    OK, mine has the 3 point mount. The O-ring popped out of the zek area in the direction of the pump, not toward the engine...I will try to get better pics here too...

  7. #5
    Senior Member earlbrown's Avatar
    Join Date
    Dec 2007
    Location
    LaGrange GA
    Posts
    285

    Default

    Are you describing #45? If so, you might be OK if you put the seal back and regrease the bearing.
    Since you heard a noise it sounds like you might have run the bearing dry and possibly smoked it.


  8. #6
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    Quote Originally Posted by CK7684 View Post
    OK, mine has the 3 point mount. The O-ring popped out of the zek area in the direction of the pump, not toward the engine...I will try to get better pics here too...

    thats still a seal for the main bearing.. Me personally i would not risk it. I would replace.. However that means removing that shaft and that means removing the motor. You could remove the jet but with a F it may be easier to pull the engine..

    you could pop the seal back in there but you would be doing so at your own risk. IMHO if it popped out once you run the risk of it doing it again. I would replace STAT. But then again im not in your shoes.
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

  9. #7
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    Quote Originally Posted by CK7684 View Post
    but I'm wondering what may have caused the problem
    Did you over grease it?
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

  10. #8
    Senior Member CK7684's Avatar
    Join Date
    Aug 2008
    Location
    Minnesota
    Posts
    550

    Default

    I havent greased it yet this year, since it hasnt been on the water much. I believe that could be part #45, but it popped out towards the jet side, and it looks like an O-ring, where the picture the part looks bigger.
    When I slowed down, the engine quit and wouldnt turn over. It did turn over later on, but I didnt start it up. I'm just hoping I didnt hurt anything too major...I guess a tear down will tell. I would like to avoid having the same thing happen again though. Could I have done something re-installing the engine??

  11. #9
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    Quote Originally Posted by CK7684 View Post
    I havent greased it yet this year, since it hasnt been on the water much. I believe that could be part #45, but it popped out towards the jet side, and it looks like an O-ring, where the picture the part looks bigger.
    When I slowed down, the engine quit and wouldnt turn over. It did turn over later on, but I didnt start it up. I'm just hoping I didnt hurt anything too major...I guess a tear down will tell. I would like to avoid having the same thing happen again though. Could I have done something re-installing the engine??

    I doubt you could have pushed that seal out when re-installing the motor.. it could have just been that bearings time... or it could have been low on grease..Who knows.. However you need to address it before trying to crank it back over.

    If nothing else at least have the bearing inspected. I dont know where you are located but i shipped my shaft/bearing to Tom and JBP. He switched out bearings and dropped the shaft on the lathe for me for a very reasonable price. If you dont have access to the tools to verify its all good to go you should call him. Im sure he could help you out with the bearing and the new seal.
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95