need help
+ Reply to Thread
Results 1 to 8 of 8

Thread:
need help

  1. #1
    Senior Member
    Join Date
    Oct 2008
    Location
    hesperia ca
    Posts
    368

    Default need help

    I have 1975 southwind jet boat 460 ford having fuel problems electric fuel pump600 cfm holley crusing about 3500 rpm its fine when I step on it I go about 100yds and run out of fuel i dont know how much fuel pressure i should have or is it to small of carburator

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Before you assume the 600cfm is too small (and it may be) I would look for supply "issues" by checking fuel lines for collapse, pinching cracks etc , cheesy little restrictive glass in line fuel filters , tanks not feeding at the same rate (if not isolated) etc Call or post up If we can help Tom

  4. #3
    southwindsforsure justsquirtin's Avatar
    Join Date
    Jul 2009
    Location
    rio linda calif
    Posts
    645

    Default

    where is your fuel filter located-before fuel pump or after-had the same issue =thought i would try a filter before my pump and it didnt work to well-

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member IRRebel's Avatar
    Join Date
    Feb 2009
    Location
    Casa Grande Arizona
    Posts
    335

    Default

    Quote Originally Posted by jetboatperformance View Post
    Before you assume the 600cfm is too small (and it may be) I would look for supply "issues" by checking fuel lines for collapse, pinching cracks etc , cheesy little restrictive glass in line fuel filters , tanks not feeding at the same rate (if not isolated) etc Call or post up If we can help Tom
    First, I beleive in most any marine application, even on a stock marine 460, 600cfm is WAY too small. Great throttle response, though, but gonna kill you on the upper end. 750 minimum, but get a good 850, particularly if you have, or plan to, mod the engine.

    I beleive your problem probably comes from collapsing fuel hoses somewhere in the system, as Tom pointed out. They need replacin' as they're too soft, for one, but think about the physics as to why its happening. The pump is working o/t trying to keep it fed at speed, causing a lot of vacuum on the suction side of the pump, hence hose collapse.

    Is the pump in good order? Regulator?

    Just my opinion

    Ray

  7. #5
    Senior Member
    Join Date
    Oct 2008
    Location
    hesperia ca
    Posts
    368

    Default

    the fuel pump is about 2 years old and the fuel filter is after the pump what kind of fuel pressure should I have the fuel lines are about 5 years old

  8. #6
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Funny but when I ran two 600's on my SBC Flatty years back Josh always teased me aout the fact that it was way over carburated and honestly he was right the fact is most "aftermarket" builds tend to be that way The Folks at QFT talked me out of 850's (went 750's) for my Tunnel hull and a 1250 (went 1050) for my Cruiser. Fact is we (my self included) always seem to want to go "big" and why not were guys right? Brian don't want to Jack your troubleshooting thread but thought this might be of interest Tom

    re your complaint BTW it still sounds like your boat is "starving" for fuel , what exact fuel pump do you have , should make at least 6+ psi to feed the Holley

    Take the test below and see (be honest!)

    CARB SIZE CALCULATOR
    :
    http://www.gtsparkplugs.com/CarbCFMCalc.html

  9. #7
    Senior Member
    Join Date
    Oct 2008
    Location
    hesperia ca
    Posts
    368

    Default

    its a posiflow thats all its says on it

  10. #8
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Quote Originally Posted by flyinbrian5 View Post
    its a posiflow thats all its says on it
    If its one of these ,IMO its deficiant in what you need /require and is likely at least part of your problem Tom

    http://www.google.com/search?hl=en&s...i=g-p1g3g-s1g5

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95