Impellor or not!
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 14 of 32

Thread:
Impellor or not!

  1. #1
    Senior Member Widetrack's Avatar
    Join Date
    Jan 2008
    Location
    Southwest corner AR
    Posts
    4,045

    Default Impellor or not!

    I got to test my new boat this weekend, YES! Boat ran good for stock 454 about 60 mph turning around 5800-5900 RPM! Well you know when I got back home out comes the stocker in goes the bigger motor! I know the increase in HP is going to probley need an impellor change I am running an A right now. The increase in HP will be around 660 double the 330 I pulled out! What would anyone suggest? I use the boat for fun not racing But, it will be tested!

    WT

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member GAWnCA's Avatar
    Join Date
    Jan 2008
    Location
    Sacramento, CA, USA
    Posts
    2,510

    Default

    I've heard of people running the "A" impeller in their boats with 650 HP but not much over that. I just sent email to a buddy who builds Berk Jet pumps and asked him. I'll let you know for sure as soon as I hear back.

  4. #3
    Senior Member W.O.T's Avatar
    Join Date
    Jan 2008
    Location
    Campo Ca
    Posts
    988

    Default

    Congrats on the new boat. With 330 HP you probably dont have an A impeller spinning that many rpms. Your tach is off or you have a much smaller impeller or both.
    Last edited by W.O.T; 03-24-2008 at 01:56 PM.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member hotbo's Avatar
    Join Date
    Feb 2008
    Location
    lake Ouachita AR
    Posts
    4,677

    Default

    Quote Originally Posted by W.O.T View Post
    Congrats on the new boat. With 330 HP you dont probably dont have an A impeller spinning that many rpms. Your tach is off or you have a much smaller impeller or both.
    your dead on my friend,no way in hell will a stock style or even mild built motor turn a A impeller 5,800 plus,something is wrong my friend.

    you should be turning around 4,600-4,800 maybe with a stone stock mill on a full A cut impeller

  7. #5
    Glendale Arizona Squirtcha?'s Avatar
    Join Date
    Jan 2008
    Location
    Glendale Arizona
    Posts
    2,368

    Default

    Quote Originally Posted by hotbo View Post
    your dead on my friend,no way in hell will a stock style or even mild built motor turn a A impeller 5,800 plus,something is wrong my friend.

    you should be turning around 4,600-4,800 maybe with a stone stock mill on a full A cut impeller
    Agreed. Speed doesn't seem to match the rpm for an A. Also agree with the 4600-4800 rpm. Possibly even 4400 depending on whether it's a Berk or Aggressor impeller.

  8. #6
    Senior Member Widetrack's Avatar
    Join Date
    Jan 2008
    Location
    Southwest corner AR
    Posts
    4,045

    Default

    Could be real loose LMAO! The tack reads correct at idle! I had an 79 SJ with a mild 460 and turned it 5800-6000 with an A impellor!
    When I had the pump apart it had A stamped on it and no bad sign of bad wear! I did test with the stock bowl on the trailer ran up to 5700 Rpm then. Changed the bowl to a JG split and the RPMs are still high! The impeller could have been resized I don't know but I will check sizes!

  9. #7
    Senior Member H20MOFO's Avatar
    Join Date
    Dec 2007
    Posts
    4,288

    Default

    Regardless it sounds like an impeller is in your future, unless your already running a stainless. I'll bet you end up with a "b" cut.
    Another Hot Boat refugee

  10. #8
    Senior Member Widetrack's Avatar
    Join Date
    Jan 2008
    Location
    Southwest corner AR
    Posts
    4,045

    Default

    Hotbo That is why I was looking for Scott S. I was going to get him to take a look at pump and placement or set! Shoe, ride plate,cav. ETC. Thanks WT

  11. #9
    jetboataholic HawaiianJet's Avatar
    Join Date
    Mar 2008
    Location
    Lexington, KY
    Posts
    2,798

    Default

    Go to this site it has a chart on it.
    http://www.arsmarine.com/Pump_Parts/impeller_chart.htm

  12. #10
    Senior Member Widetrack's Avatar
    Join Date
    Jan 2008
    Location
    Southwest corner AR
    Posts
    4,045

    Default

    Quote Originally Posted by H20MOFO View Post
    Regardless it sounds like an impeller is in your future, unless your already running a stainless. I'll bet you end up with a "b" cut.
    Sounds that way Im Thinking I got too much clearence will check that too! Thanks WT

  13. #11
    Senior Member Ken F's Avatar
    Join Date
    Dec 2007
    Posts
    557

    Default


    You might look at your impeller and compare the cut to this chart.
    Your impeller may have started out life as an A but could have been cut down to a B, C, or even D.

    Hope this helps,
    Ken

  14. #12
    No Sandbar To Far sanger rat's Avatar
    Join Date
    Dec 2007
    Location
    MI
    Posts
    3,276

    Default

    What are the clearances on the wear ring?
    Quote Originally Posted by One More Year View Post
    The only blab's I will even be a part of is just when it is me they are talking about. Aaaah yes I can see a few good looking shiny tall deck motors on the beach, with barely enough fuel to get back to the launch saying, "Holy crap how fast you think that Daytona was going man? That's like the 20th time he's gone by today?"

  15. #13
    About 500' AGL MudPumper's Avatar
    Join Date
    Jan 2008
    Location
    Santa Clarita
    Posts
    2,470

    Default

    Quote Originally Posted by Widetrack View Post
    Could be real loose LMAO! The tack reads correct at idle! I had an 79 SJ with a mild 460 and turned it 5800-6000 with an A impellor!
    When I had the pump apart it had A stamped on it and no bad sign of bad wear! I did test with the stock bowl on the trailer ran up to 5700 Rpm then. Changed the bowl to a JG split and the RPMs are still high! The impeller could have been resized I don't know but I will check sizes!

    A mild 460 wont turn an A to 5800-6000 rpm either. Something is off.

  16. #14
    Senior Member hotbo's Avatar
    Join Date
    Feb 2008
    Location
    lake Ouachita AR
    Posts
    4,677

    Default

    Quote Originally Posted by Widetrack View Post
    Hotbo That is why I was looking for Scott S. I was going to get him to take a look at pump and placement or set! Shoe, ride plate,cav. ETC. Thanks WT
    excellent idea my friend

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95