ignition problems
+ Reply to Thread
Results 1 to 10 of 10

Thread:
ignition problems

  1. #1
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default ignition problems

    So I recently upgraded up my dizzy to a Mallory comp 9K and its running off a Promaster coil.

    Yesterday I was testing spark and I have none! Battery is fully charged i verified with a multimeter voltage going in to the coil. I tested the out put with a spark plug and I am getting spark from the output of the coil, But no spark at the plugs them self's. Rotor is in good shape.

    Any one have any suggestions or things to check?
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member GRoper's Avatar
    Join Date
    Jun 2009
    Posts
    2,021

    Default

    hmmm.... a ground somwhere i would say but what the f do i know. I just usually thrash around till i stumble apon sumthin. How did you test the plug? Couldnt hurt to replace the rotor. they dont cost much just too eliminate the possibility.

  4. #3
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    the rotor is in great shape. I think its a wiring problem somewhere. when testing voltage going in to the Ballast resistor its only at 11.71. Does it need 12 volts? I know coming out it will be diminished. I did the whole credit card thing on the Optical lens and it does drops volts to about 11.69/11.68.
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member lowgear351's Avatar
    Join Date
    Jul 2009
    Location
    newcastle ca
    Posts
    212

    Default

    try looking on he mallory web site all the troubleshooting info is on their . try your old distributor just to narrow down the issue.

  7. #5
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    I think its the battery. It drained rather quickly just turning it over a couple of times. I left it to charge last night and its already dead plus it seems to recover quickly. I also took a volt meter to it under load 10.20 no bueno.
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  8. #6
    Horsepower sells Engines lefty's pride's Avatar
    Join Date
    Nov 2009
    Location
    Langley, B.C. Canada
    Posts
    402

    Default

    11.6 before the resistor not good you need full battery voltage there but is this Mallory a electronic ing? if so you should not need the resistor that was just for the points as fair as i know. if you have power coming out of the coil is good you have a wire problem to the plugs so check Resistance of the wire, then cap and rotor is there any discoloration in the rotor or the cap carbon tracking under the cap. lastly is the wires casing good could be arcing to the motor through the casing fire it up at night and look for the arcs, or if you daring run your hands over the the wires and see if you get zapped
    "Horsepower sells Engines but torque wins races."
    "winners never quit, quitters never win
    those who never win and never quit are idiots"
    "if at first you don't succeed redefine success"
    "why is there never time to do it right, but there is aways time to do it twice"

  9. #7
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    Quote Originally Posted by lefty's pride View Post
    11.6 before the resistor not good you need full battery voltage there but is this Mallory a electronic ing? if so you should not need the resistor that was just for the points as fair as i know. if you have power coming out of the coil is good you have a wire problem to the plugs so check Resistance of the wire, then cap and rotor is there any discoloration in the rotor or the cap carbon tracking under the cap. lastly is the wires casing good could be arcing to the motor through the casing fire it up at night and look for the arcs, or if you daring run your hands over the the wires and see if you get zapped
    got a new battery and getting correct voltage now. The ballest resistor is for the coil so it does not burn up.

    I decided to bring it up to TDC and look where the rotor was. It was way off so i rest it and locked it down and now i get spark i just have to tool with it to get it to start.
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  10. #8
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    Incase someone ever has a problem like i did. I found the problem.




    This is the plug from the dizzy. Ground wire and trigger wore broke lose from the connector.

    "well theres your problem"
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

  11. #9
    Team CJ460 Just Electric's Avatar
    Join Date
    Mar 2008
    Location
    granada hills
    Posts
    2,191

    Default

    hey robert its usually something small like that glad you got it fixed

  12. #10
    What the Hell is That? 72Hondo's Avatar
    Join Date
    Apr 2008
    Location
    Denton, TX
    Posts
    1,633

    Default

    Quote Originally Posted by Just Electric View Post
    hey robert its usually something small like that glad you got it fixed
    Thats why the boat is named "Loose Connection"
    Quote Originally Posted by Kyle View Post
    Log off and go float, hang in the party coves, Show and shine on the trailer, fill up the boat, wax it, v-drive, jet, outdrive, and if you got a canoe and your reading this, you sir, need to phucking upgrade.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95