need advise again
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 14 of 22

Thread:
need advise again

  1. #1
    Senior Member hydroman916's Avatar
    Join Date
    Sep 2008
    Location
    sacramento
    Posts
    1,432

    Default need advise again

    I just spent a sh*t load on my pump, I rebuilt the pump, new wear ring and installed a stainless impeller, I was tryin to correct my out of the hole accel, the boat revs up and dosnt go, if I roll into it its better, so I was told to rebuild and install the stainless impeller, well I did and it does the same mother frickin thing, what should I try or do??????????????????????????????????
    get blown or get blown away

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    tintingsandiego krusn56's Avatar
    Join Date
    Oct 2008
    Location
    San Diego
    Posts
    1,063

    Default

    I have a preloader on mine...seems to help a bit.....
    Made In The Shade

    Custom Window Tinting

  4. #3
    Senior Member Luckie Stiff's Avatar
    Join Date
    Dec 2007
    Location
    Bakersfield
    Posts
    1,189

    Default

    Who did the rebuild? Krusn's right, add an inducer and you'll be way happy.
    "Don't you realize that there are already enough people in the world to hate without you putting in so much effort to give me another?"

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member hydroman916's Avatar
    Join Date
    Sep 2008
    Location
    sacramento
    Posts
    1,432

    Default

    I did it with toms help
    get blown or get blown away

  7. #5
    Senior Member cyclone's Avatar
    Join Date
    Dec 2007
    Posts
    3,620

    Default

    what type of loader do you have? what is the impeller cut? how much horsepower does the engine put out?

  8. #6
    Senior Member Fonz69's Avatar
    Join Date
    Jan 2008
    Location
    Frozen Tundra, WI
    Posts
    620

    Default

    Sent you a PM

  9. #7
    No Sandbar To Far sanger rat's Avatar
    Join Date
    Dec 2007
    Location
    MI
    Posts
    3,276

    Default

    Get a prop.
    Quote Originally Posted by One More Year View Post
    The only blab's I will even be a part of is just when it is me they are talking about. Aaaah yes I can see a few good looking shiny tall deck motors on the beach, with barely enough fuel to get back to the launch saying, "Holy crap how fast you think that Daytona was going man? That's like the 20th time he's gone by today?"

  10. #8
    Senior Member hydroman916's Avatar
    Join Date
    Sep 2008
    Location
    sacramento
    Posts
    1,432

    Default

    Quote Originally Posted by cyclone View Post
    what type of loader do you have? what is the impeller cut? how much horsepower does the engine put out?
    Im unsure of what type loader...I just installed an A cut ss imp...engine puts out 741 at 5900rpm...
    get blown or get blown away

  11. #9
    Senior Member hydroman916's Avatar
    Join Date
    Sep 2008
    Location
    sacramento
    Posts
    1,432

    Default

    Quote Originally Posted by sanger rat View Post
    Get a prop.
    Aaahhhh!!!! seen my avatar...I gots one emmm tooo!!!
    get blown or get blown away

  12. #10
    LP-25.com Infomaniac's Avatar
    Join Date
    Dec 2007
    Location
    New Port Richey, FL
    Posts
    16,855

    Default

    Start measuring pressures.

    And check the packing.
    If For Some Reason I Do Something Worthy Of Recognition. God Provided The Ability And Deserves The Credit.


    QE 439 Twin Turbo

  13. #11
    Senior Member Oldsquirt's Avatar
    Join Date
    Dec 2007
    Location
    NorCal
    Posts
    979

    Default

    Quote Originally Posted by hydroman916 View Post
    ...I just installed an A cut ss imp...engine puts out 741 at 5900rpm...
    What brand impeller? New or used? If used, did you confirm cut size by measuring it?

    Once it hooks up, what peak rpm are you turning?

  14. #12
    Senior Member
    Join Date
    Dec 2007
    Location
    Concord, CA
    Posts
    939

    Default cavitation

    If you stomp on at from an idle, you may be cavitating the pump. Needs to get some flow before it will hook up. What are your rpm's doing? Similar to me, run at 5,900 rpms hooked up, but off idle, it would hit upwards of 8,100+/- till it hooked up, then drag the rpm down to 5,900. I put a rev limiter at 6,000, and it helped. Otherwise I have to roll into it.

    Jerry

  15. #13
    Horsepower sells Engines lefty's pride's Avatar
    Join Date
    Nov 2009
    Location
    Langley, B.C. Canada
    Posts
    402

    Default

    totally going to go with the preloader advice from what i have heard it is the way to go not that i have one but.. no super negatives i have heard
    "Horsepower sells Engines but torque wins races."
    "winners never quit, quitters never win
    those who never win and never quit are idiots"
    "if at first you don't succeed redefine success"
    "why is there never time to do it right, but there is aways time to do it twice"

  16. #14
    Senior Member hot-rod 21's Avatar
    Join Date
    Apr 2009
    Location
    se michigan
    Posts
    371

    Default

    do you have a f.t.n. set up.? what size insert do you have in?

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95