top speed problem/question
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 14 of 29

Thread:
top speed problem/question

  1. #1
    Junior Member
    Join Date
    Oct 2010
    Location
    LaPorte, Indiana
    Posts
    20

    Default top speed problem/question

    I have a 1975 sanger super jet. its 18ft long, 1700lbs with a 455 olds. I was told the engine was rebuilt last year and had 513hp. Today I only got a best top speed of 46mph on my gps. The engine seems to be running pretty good. The boat gets up on plane pretty fast and gets to 46 pretty fast, but then it stops. Is my boat just too heavy? Is that how fast those boats are? Or is it my drive? It just seems like it should be doing a lot better than that. any suggestions? thanks

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Wet
    Wet is offline
    Banned
    Join Date
    Dec 2007
    Location
    East Hampton, CT
    Posts
    4,957

    Default

    What kind of RPM's are you turning?

  4. #3
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Default

    What RPM is the engine turning???

    A friend of mine had the same boat (very quick) and it pulled like a Bull to 65 mph with a 330 HP 454 (A) Imp >sorry I don't recall the RPM.
    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Junior Member
    Join Date
    Oct 2010
    Location
    LaPorte, Indiana
    Posts
    20

    Default

    I dont know, my tach is broken. I will try and get a tach. thanks

  7. #5
    Junior Member
    Join Date
    Oct 2010
    Location
    LaPorte, Indiana
    Posts
    20

    Default

    do you think its my jet drive. ive got the 12jb-a? I have been wanting to rebuild it, but would that cause that much of a difference. consideration your friends boat as of right now is a lot faster than mine. I guess I just wanted to see if this was normal, I was expecting a little more out of her

  8. #6
    History Repeating Storz's Avatar
    Join Date
    Nov 2008
    Location
    Fuquay-Varina, NC
    Posts
    596

    Default

    If the motor seems to be pulling strong chances are its the pump. My WJ12 is getting a rebuild this winter, it would only run 51mph at 5100RPM last year
    '84 Laser LTV - Restoration in progress
    '77 Caribbean

  9. #7
    Junior Member
    Join Date
    Oct 2010
    Location
    LaPorte, Indiana
    Posts
    20

    Default

    alright, looks like a pump rebuild is in the future for me. Thanks a lot for the help

  10. #8
    Senior Member Oldsquirt's Avatar
    Join Date
    Dec 2007
    Location
    NorCal
    Posts
    980

    Default

    Quote Originally Posted by 173rdbrandon View Post
    alright, looks like a pump rebuild is in the future for me. Thanks a lot for the help
    Fix your tach FIRST, then take it out for a run and see what the motor is actually turning. You need this info before condemning the pump.

  11. #9
    gn7
    gn7 is offline
    Senior Member gn7's Avatar
    Join Date
    Jan 2008
    Posts
    25,975

    Default

    Quote Originally Posted by 173rdbrandon View Post
    I have a 1975 sanger super jet. its 18ft long, 1700lbs with a 455 olds. I was told the engine was rebuilt last year and had 513hp.
    And he said this to you with a totally straight face.



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

  12. #10
    Junior Member
    Join Date
    Oct 2010
    Location
    LaPorte, Indiana
    Posts
    20

    Default

    Quote Originally Posted by gn7 View Post
    And he said this to you with a totally straight face.
    reallyyyyy........ that bad huh

  13. #11
    Senior Member jorndy's Avatar
    Join Date
    Sep 2010
    Location
    Some Where Between lost and found
    Posts
    580

    Default

    Quote Originally Posted by 173rdbrandon View Post
    reallyyyyy........ that bad huh
    Better hurry up with the tach and run it, another week and you will have ice on the water up there.

  14. #12
    Super Moderator HammerDown's Avatar
    Join Date
    Dec 2007
    Location
    The Right Coast/SE-PA
    Posts
    5,488

    Default

    Quote Originally Posted by 173rdbrandon View Post
    reallyyyyy........ that bad huh
    That HP on a 455, not saying it can't be done but it may be a stock low HP engine > get the tach and report back with max RPM's .
    If it's infact an A imp, that will tell part of the story.
    <img src=http://www.performanceboats.com/gallery/data/500/medium/06-30-11_1234.jpg border=0 alt= />

  15. #13
    gn7
    gn7 is offline
    Senior Member gn7's Avatar
    Join Date
    Jan 2008
    Posts
    25,975

    Default

    Quote Originally Posted by 173rdbrandon View Post
    reallyyyyy........ that bad huh
    No, not really. So long as the motor looks like the one on the cover of this book, was built by Joe Mondello, Dick Miller, or Warren Johnson. Then I am sure it does.



    100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

  16. #14
    Senior Member
    Join Date
    Dec 2007
    Location
    Newbury Park, Ca/Mohave Valley, Az
    Posts
    8,169

    Default Pump??

    Quote Originally Posted by 173rdbrandon View Post
    alright, looks like a pump rebuild is in the future for me. Thanks a lot for the help
    Ah, no. As mentioned, fix the tach, and/or speedometer.. Or are you using a GPS?? Either way, if the pump "pulls hard" up to that point I doubt the low top speed is a pump issue... I have a very stock 455 that runs 57MPH, (down river), and quite frankly, there is something missing from this story??? More than likely your 513 HP is a bit of a fish tale.. However, I doubt mine is making any more than the original 330HP and does run 57 on GPS w/ an "A" impeller.... Something is fishy here....Maybe the boat has a huge hook in it??......Maybe the installed angle of the pump is way off? Maybe the ride plate, (if so equipped), is driving the nose in...??.....Something just doesn't sound right unless the engine is a total turd, but then it would be a turd down low as well???.... Fix the tach before you do anything..

    Ray
    Last edited by Moneypit; 11-08-2010 at 01:14 AM.
    LOUD BOATS SAVE LIVES

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95