got my new bell housing and have a bit of an issue
+ Reply to Thread
Results 1 to 4 of 4

Thread:
got my new bell housing and have a bit of an issue

  1. #1
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default got my new bell housing and have a bit of an issue

    I think the answer is yes but is there any reason why i cant put the new bellhousing on a bandsaw and cut out that relief like is on the old one? it is rubbing on the E pump and is cauing me some real friggin headaches.

    Oh.. and any suggestions on how to mount an alternator on the front of a SBC with out using a front engine mount in a normal 4 point set up?



    the pump area.


    this is the front mount that i broke the hell out of today.. i want to go back to a normal 3 point setup but i need to figure out how to mount the alt.



    thanks...
    Last edited by Delemorte; 05-14-2011 at 05:02 PM.
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    anyone?
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

  4. #3
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,463

    Default

    Sean I guess I lost sight of the fact that you have a combination of 3 point and 4 point mounts , you may want to think about re mounting the front in the traditonal (block side setup) The "span" between the 4 point front and 3 point rear is great and is ripe for breakage IMO Tom
    check your PMs ! Tom

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member Delemorte's Avatar
    Join Date
    Mar 2008
    Location
    Charlotte, NC.
    Posts
    1,553

    Default

    Quote Originally Posted by jetboatperformance View Post
    Sean I guess I lost sight of the fact that you have a combination of 3 point and 4 point mounts , you may want to think about re mounting the front in the traditonal (block side setup) The "span" between the 4 point front and 3 point rear is great and is ripe for breakage IMO Tom
    check your PMs ! Tom

    that was my thought as well.. i think i need to move it back to a tradition three point all the way around and move the alternator.
    Quote Originally Posted by jetboatperformance View Post
    the ensueing fire would likely be extinguished by the sinking however

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95