ignition box problems? help!!!
+ Reply to Thread
Results 1 to 14 of 14

Thread:
ignition box problems? help!!!

  1. #1
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default ignition box problems? help!!!

    Ignition boxes? Is there anything you can do with a ford not to run an ignition box? I've gone through three msd boxes in the last 6 years. I ran my boat Friday set timing and tuned the carb, then I changed fuel filters and a fuel line so I went to start it make sure the fuel was flowing and no leaks and no spark and the box not workink. So I unplugged it grounded to the block new power wires rehooked up tried to trouble shoot and still nothing. So now I'm tired of msd and wondering what product I should buy or is there a way to not run a box? Dui is a boxless distributor, but almost 400 bucks, I've rand 2 6al and this last one 6marine,just don't want msd again!!

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member
    Join Date
    Jul 2008
    Location
    Kingman/Golden Vly, Az
    Posts
    1,278

    Default

    i think (could be wrong) alot of Ford people run a Petronix distributor...also...i dont see anything wrong with the stock HEI system!...just sayin' my .02 cents FastRat

  4. #3
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default ok

    Quote Originally Posted by FastRat View Post
    i think (could be wrong) alot of Ford people run a Petronix distributor...also...i dont see anything wrong with the stock HEI system!...just sayin' my .02 cents FastRat
    Thanks I bought a cheap stock style box ill try it see what happens and check out those petronix see what their all about thanks for your change

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member Schiada 201's Avatar
    Join Date
    Oct 2009
    Location
    Orlando.FL
    Posts
    672

    Default

    I took off all my expensive MSD stuff. You can buy a HEI off e bay from Skip White for $ 49.00 , been running one for 2 yrs now. Trouble free, runs great.

  7. #5
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default thanks

    Quote Originally Posted by Schiada 201 View Post
    I took off all my expensive MSD stuff. You can buy a HEI off e bay from Skip White for $ 49.00 , been running one for 2 yrs now. Trouble free, runs great.
    I will see what I can find on ebay for the skip thite thanks if I can't find him maybe a link? Will let you know.

  8. #6
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default nice

    Quote Originally Posted by Schiada 201 View Post
    I took off all my expensive MSD stuff. You can buy a HEI off e bay from Skip White for $ 49.00 , been running one for 2 yrs now. Trouble free, runs great.
    Those are bad ass and lifetime warranty super bad ass!!! Looks like they are good quality too think ill try one can buy 4 of those units for the price of 1msd box that will be bad next year!! Thanks buddy those pertronix are nice too! Anyone running these products please chime in would like to hear more about them

  9. #7
    Speed is a function of $$ mightylandwalrus's Avatar
    Join Date
    Jun 2010
    Location
    Rio Medina, Texas
    Posts
    119

    Default

    Quote Originally Posted by Schiada 201 View Post
    I took off all my expensive MSD stuff. You can buy a HEI off e bay from Skip White for $ 49.00 , been running one for 2 yrs now. Trouble free, runs great.
    Found some HEI distributors on Ebay but they look a little "bulky".... do they fit with a tunnel ram set-up. Seems like it would be too close to the body of the intake??? Anyone make this work before?
    Beer is the answer... but I dont remember the question.

  10. #8
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default re

    Quote Originally Posted by mightylandwalrus View Post
    Found some HEI distributors on Ebay but they look a little "bulky".... do they fit with a tunnel ram set-up. Seems like it would be too close to the body of the intake??? Anyone make this work before?
    The guy said the big cap is around 5 to 6 inchis when I called I checked my distributor now is about 5/1/2 with the outside clips hope that helps you when I get mine ill take pictures before I install and after I install it. they also have one that is a small housing the same size as a points dis you just have to run a stand alone coil with 1 12 volt power wire to the coil then 2 wires from the dist hook to the coil so basically same just not as bulkey
    Last edited by 79sleek; 06-20-2011 at 03:22 PM. Reason: fix

  11. #9
    Senior Member nosfomoco's Avatar
    Join Date
    Dec 2009
    Location
    Sac, Ca
    Posts
    136

    Default

    Just my 2 cents, I ran an MSD digital 6 box with my Ford and a MSD Pro Billet Dizzy for 7 years with no problemo. I did mount the box under the dash attached to my bulkhead. I think the digital 6 is built different that the 6al though. I had to run that dizzy to clear tunnel ram.

    Name:  393068991162245_3300_1-med.jpg
Views: 378
Size:  38.9 KB
    Last edited by nosfomoco; 06-20-2011 at 09:13 PM.
    1978 Eliminator Sport Cruiser 20.5ft BBF 460!

  12. #10
    Senior Member motomattox's Avatar
    Join Date
    Apr 2011
    Posts
    162

    Default

    Quote Originally Posted by nosfomoco View Post
    Just my 2 cents, I ran an MSD digital 6 box with my Ford and a MSD Pro Billet Dizzy for 7 years with no problemo. I did mount the box under the dash attached to my bulkhead. I think the digital 6 is built different that the 6al though. I had to run that dizzy to clear tunnel ram.

    Name:  393068991162245_3300_1-med.jpg
Views: 378
Size:  38.9 KB
    Damn that thing looks sunk what happened????
    "Keep talking...it aint often I get to hear a genius speak"

  13. #11
    Senior Member nosfomoco's Avatar
    Join Date
    Dec 2009
    Location
    Sac, Ca
    Posts
    136

    Default

    Well I was out at camp far west lake doing some shakedown runs because I had just straightened the bottom of boat, that kachina had a porpoise problem and would unload and load the pump sometimes(really hard on pump housing) up top. I just did a run and got 93.3 mph on gps when I decided to try and back that number up, I held in it for a little to long and the pump housing broke right in front of impeller. I had about 10 seconds to floor it to shore and thats as close as I got. Atleast I didn't loose it at the bottom of the lake. It took 10 guys and about 3 hours to get back on trailer.
    1978 Eliminator Sport Cruiser 20.5ft BBF 460!

  14. #12
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default got one

    Quote Originally Posted by Schiada 201 View Post
    I took off all my expensive MSD stuff. You can buy a HEI off e bay from Skip White for $ 49.00 , been running one for 2 yrs now. Trouble free, runs great.
    Got my distributor from whites, installed it this afternoon 460 fired right up no problems just had to grind the edge of the water outlet down a little well a lot more to clear the distributor but runs great and 50 bucks with a lifetime garantee awsome thanks for the tip really appretiate that my buddy was impressed with this dist too he said he's going to get one for his ford thanks
    Attached Images Attached Images  

  15. #13
    '79' Eliminator sprint bailey's Avatar
    Join Date
    Feb 2008
    Location
    Concord, CA
    Posts
    25

    Default

    just curious how old is your alternator? Had same problem with my msd went threw 3 boxes changed alt. and no more problem.

  16. #14
    Senior Member 79sleek's Avatar
    Join Date
    May 2011
    Location
    Wyoming
    Posts
    178

    Default alt

    Quote Originally Posted by bailey View Post
    just curious how old is your alternator? Had same problem with my msd went threw 3 boxes changed alt. and no more problem.
    Its about 4 years old my buddy checked it said it was ok, maybe ill take it in and have it tested. Thanks for the info ill keep an eye on it.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95