Random Tach
+ Reply to Thread
Results 1 to 3 of 3

Thread:
Random Tach

  1. #1
    The Good mrjoshua's Avatar
    Join Date
    Aug 2010
    Location
    Albuquerque NM
    Posts
    483

    Default Random Tach

    I have a SW tach in my boat. probably 20 yrs old. It sat in the old one and worked fine off a mallory dist. It sat for some time and now in my new boat with HEI it jumps all over. Sometimes it will stay at 3500 rpm after the key is off and then comes back to zero after you click it on again. Other times while driving it jumps all over. and then sometimes seems to work just fine. I checked the ground and it seems pretty solid. I know if you have the wrong cylinder setting it can cause this but it worked well in the old boat with a v-8. I also get inconsistant readings on my fuel guages. sometimes they are accurate and other times way off. Im not sure if my entire system is out of whack or what.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    Quote Originally Posted by mrjoshua View Post
    I have a SW tach in my boat. probably 20 yrs old. It sat in the old one and worked fine off a mallory dist. It sat for some time and now in my new boat with HEI it jumps all over. Sometimes it will stay at 3500 rpm after the key is off and then comes back to zero after you click it on again. Other times while driving it jumps all over. and then sometimes seems to work just fine. I checked the ground and it seems pretty solid. I know if you have the wrong cylinder setting it can cause this but it worked well in the old boat with a v-8. I also get inconsistant readings on my fuel guages. sometimes they are accurate and other times way off. Im not sure if my entire system is out of whack or what.
    Was the Mallory a point type? possibly the Older tach is simply not compatible re your other guages , sd's like you may have a dash ground problem Tom

  4. #3
    The Good mrjoshua's Avatar
    Join Date
    Aug 2010
    Location
    Albuquerque NM
    Posts
    483

    Default

    Quote Originally Posted by jetboatperformance View Post
    Was the Mallory a point type? possibly the Older tach is simply not compatible re your other guages , sd's like you may have a dash ground problem Tom
    Hey Tom. Yeah it was an old points set up. I have a terminal block under the dash with dual ground wires on either end and then daisy chained the interim terminals for the guage hook ups. whould this cause a problem? I thought it might just be too old and not be compatible with HEI. Like with most things i have little or no expertise and electrical is definately one of them.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95