Knocking Noise, and no start when Hot help
Results 1 to 4 of 4

Thread:
Knocking Noise, and no start when Hot help

  1. #1
    Senior Member
    Join Date
    Mar 2008
    Location
    anaheim hills ca
    Posts
    137

    Default Knocking Noise, and no start when Hot help

    ok so this is the third time being towed in, shitty, so i hear a knocking noise from the pump and yes i disconected the driveshaft and the noise goes away so i know its the pump, and the noise increases with rpm, my other problem is i drive around and get everything warmed up shut it down and it wont restart, wait about 30 min when everything cools down and it fires up no problem, now i just replaced the entire fuel system including pump and filters, i checked and i have fuel and air but no spark. another thing is i mounted my coil directly to my head, is that getting to hot and causing it to stop working. idk so i have a horible knocking noise and a motor that wont run......and a river trip in two weeks help.........
    Quick reply to this message Reply  

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member jet pilot's Avatar
    Join Date
    Jul 2009
    Location
    Hesperia California
    Posts
    354

    Default

    are you sure that your not getting water in the cylinders, water don't compress well! don't ask me how I know this. definitely move the coil, mount it off the engine if you can or on top of the manifold.
    Quick reply to this message Reply  

  4. #3
    Senior Member jetboatperformance's Avatar
    Join Date
    Dec 2007
    Location
    Atascadero Calif
    Posts
    7,464

    Default

    If you have isolated you noise to your jet by removing the drive line from the "mix' then you have answered your own question and need to address the jet issue , seperate from that if your having a "hot soak" problem with the ignition its likley a component (CD box ,coil, ballast or distributor trigger possibly even an ignition switch , if you were to describe in detail the rest of the ignition (type brand etc , it might aid in the diagnosis Tom
    Quick reply to this message Reply  

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member
    Join Date
    Mar 2008
    Location
    anaheim hills ca
    Posts
    137

    Default

    so i got the ich right after i wrote this i went and pulled the pump out im going to take it down to the shop tomarrow, as far as the no start, i have a msd 6a ignition, msd coil mounted to the head witch i will move,
    Quick reply to this message Reply  

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in


Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95