07 496 knock sensor computer issue
+ Reply to Thread
Results 1 to 12 of 12

Thread:
07 496 knock sensor computer issue

  1. #1
    Junior Member
    Join Date
    Apr 2009
    Posts
    19

    Default 07 496 knock sensor computer issue

    07 496 HO boat with 120 hours- continues to have knock sensor reading and restards motor-new knock sensors and now mecahnic says that its the computer program and is to sensitive-he tried a new Merc updated program but still not solving the issue-says they will try a whipple program $700 and if that does nt worka new computer $2000- does this sound correct? I use the boat little and has been in shop 4 times same issue-in shop now for 1.5 months

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    custom boat lover
    Join Date
    Feb 2009
    Posts
    498

    Default

    Quote Originally Posted by electros View Post
    07 496 HO boat with 120 hours- continues to have knock sensor reading and restards motor-new knock sensors and now mecahnic says that its the computer program and is to sensitive-he tried a new Merc updated program but still not solving the issue-says they will try a whipple program $700 and if that does nt worka new computer $2000- does this sound correct? I use the boat little and has been in shop 4 times same issue-in shop now for 1.5 months
    [IMHO] I would say no, You should think about finding a new mercruiser service dealer only, That will take the time to find the real problem. Or the shop you are using now should be on the phone with mercruiser tech support as their back up while working on it, With or without warranty, Mercruiser will help a mercruiser service dealer out in finding a problem oneway or another, And if they have called already then have them try a different tech support guy.
    It's 100% stock Right???
    What City/State are you in???
    Last edited by Boat Tech; 10-14-2009 at 12:56 AM.

  4. #3
    Junior Member
    Join Date
    Apr 2009
    Posts
    19

    Default

    I am in the OC but the boat is in Havasu

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    mo balls than $cents$ IMPATIENT 1's Avatar
    Join Date
    Dec 2007
    Location
    hugo,okla
    Posts
    11,727

    Default

    Quote Originally Posted by electros View Post
    07 496 HO boat with 120 hours- continues to have knock sensor reading and restards motor-new knock sensors and now mecahnic says that its the computer program and is to sensitive-he tried a new Merc updated program but still not solving the issue-says they will try a whipple program $700 and if that does nt worka new computer $2000- does this sound correct? I use the boat little and has been in shop 4 times same issue-in shop now for 1.5 months
    you could have something as simple as something on the accessory drive of the motor cliking or knocking and the knock sensor will pick it up. has he tried to read the knock sensor with the drive belt off the motor? failed gimble bearing will cause a knock sensor to read false as well

    take it to another dealer, that guy don't know shit.

    Dare to be different, if it turns out great you can claim you planned it that way.

    Jetboatperformance.com

  7. #5
    custom boat lover
    Join Date
    Feb 2009
    Posts
    498

    Default

    Quote Originally Posted by electros View Post
    I am in the OC but the boat is in Havasu
    Their is a few good mercuriser shops out there, Or their is a few out here within your area also. Ask around who is the best 496 shop for hard to find stuff.

  8. #6
    Junior Member veltvedia's Avatar
    Join Date
    Oct 2009
    Location
    United States
    Posts
    9

    Default 07 496 knock sensor computer issue

    come on 27 views and no one can help me... someone has to know something....

    even if someone could tell me how to install a knock sensor and how to wire it into the ls harness into the ecu id be happy with that

  9. #7
    Senior Member HALLETT BOY's Avatar
    Join Date
    Dec 2007
    Location
    Newbury Park Ca
    Posts
    779

    Default

    could be the infamous GM piston slap or a rod / main bearing too loose

  10. #8
    Senior Member GT Jets's Avatar
    Join Date
    Jun 2008
    Location
    Morgan Hill
    Posts
    2,234

    Default

    Could be a broken/loose motor mount too. If it uses the standard piezio knock sensor, you could try using some silicone on the threads and installing it less tight, as an experiment anyways.

    GT
    GT


    Quote Originally Posted by Quickjet View Post
    Put a 300 on the back of it, Flywheel it and a nosecone. $15,000 later you'll have a 65 mph pile of shit......

  11. #9
    New here Beer:30's Avatar
    Join Date
    Feb 2008
    Location
    Bakersfield, CA
    Posts
    4,219

    Default

    I would agree that there is something amiss - other than the NEW sensors and the ECM reflash. Buick turbo regals were very "noisy" in the knock department due to the exhaust grumbling via torque moving the engine around and also the long, hot down pipe from the turbo. It would set off the knock sensor all over the place. A fix was to put a ratchet strap on the pass side of the motor - to the frame. Snug the motor down to the frame so it can't move and the knock readings would go away.

    If there is something rattling around on the motor or tapping against it during cruise, it would trick the sensor(s).
    Quote Originally Posted by gn7 View Post
    EFI is the wave of the future. There can be no denying it. Electronics have been on the leading edge of our entire lives. Not only os the magneto dead, but the standard issue CDI is wavering. Its all about total fuel, air AND spark control. Anybody that thinks its not has their head up their ass.


    2001 SleekCraft 30' Heritage SSB, open-bow mid-cuddy. 496HO / Bravo-I.

  12. #10
    Boat Nut sleekcrafter's Avatar
    Join Date
    Dec 2007
    Location
    South Elgin, Il.
    Posts
    5,131

    Default

    Sounds like you need to find a new shop, these guys are just parts swappers, and thats as far as they will take it. Find a good Mercuiser certified shop / tech, this will get you much closer to finding the root of the problem.
    Upper Midwest Power Boat Association
    DRAG BOAT RACING UMPBA #926


  13. #11
    jcm
    jcm is offline
    Member
    Join Date
    Oct 2008
    Posts
    67

    Default

    Have run into this a couple times and it turned out to be a bad injector, the injector was not spraying correctly causing the engine to knock. To see if this is the problem engine needs to be run under load with the cds hooked up and 1 cyl shut down at a time to find which one lacks responce.

  14. #12
    Senior Member Mrs.HLB's Avatar
    Join Date
    Dec 2007
    Location
    Corona, Ca
    Posts
    308

    Default

    Don't know what shop you are using just skimmed the notes real quick but try ROB at Quality performance my bravo was out of warranty in 05 and it discetigrated on the lake he called mercury and they replaced the parts and all I had to pay for was the labor. Tbill was $4100.00 I paid $900.00 He is a higher on his pricing comapered to other shops in the area. But they are good there never ever had a problem. Also had a routine annual service and the person before that worked on it tore a rubber boot in the gimble area and siliconed it back up. He asked who did the service Itold him and it got fixed for free it was also a 300.00 part here is his # 951 735 5503 Rob clarke they are in Corona 2195 railroad Street

    Mr HLB

    Quote Originally Posted by electros View Post
    07 496 HO boat with 120 hours- continues to have knock sensor reading and restards motor-new knock sensors and now mecahnic says that its the computer program and is to sensitive-he tried a new Merc updated program but still not solving the issue-says they will try a whipple program $700 and if that does nt worka new computer $2000- does this sound correct? I use the boat little and has been in shop 4 times same issue-in shop now for 1.5 months

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95