????
+ Reply to Thread
Results 1 to 4 of 4

Thread:
????

  1. #1
    Broke and Pissed nightrider go's V-drive's Avatar
    Join Date
    Oct 2009
    Location
    sag. mich.
    Posts
    74

    Default ????

    replaced seals on prop. shaft....greased it,,took it out boat stayed dry,,,first time I cranked it up it started looking like a sprinkler,,what did I do wrong???!! It's a snapring,,simple set up thought it was a no brainer,,turns out I'm the one with no brain,,,,water p/u off bottom of boat, run though v-drive gear box and into coupleing that holds the seals.. thanks ,,keith

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member
    Join Date
    Jun 2010
    Posts
    2,923

    Default

    I have heard of a prop seal made by a place called lasdrop thats supposed to be good for 12000 or so rpms costs about 100 bucks -either the seals arent good or your shaft is bent or the stuffing box is all wopped out

  4. #3
    Broke and Pissed nightrider go's V-drive's Avatar
    Join Date
    Oct 2009
    Location
    sag. mich.
    Posts
    74

    Default

    worked on it today,,,think the slotted fiber bushing might be worn out need to find a place to order these..........also found fiber bushing was pushed up to where it was half covering the water inlet hole, that would send the water stream at the seal,,instead of at the shaft.....that and the fiber bushing allowing the shaft or coupling to wobble????????
    Last edited by nightrider go's V-drive; 08-04-2010 at 06:53 PM.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Jackwagon Patrolman Rexone's Avatar
    Join Date
    Dec 2007
    Location
    The Earth
    Posts
    11,644
    Blog Entries
    24

    Default

    Nightrider, Jim Wilkes should have those bushings. Give him a call as I know he's busy and doesn't check the forum daily.

    Also make sure your seals are riding on a smooth section of shaft. If necessary change the hose length to accomplish this. From what you have said though the bushing is likely your problem. If you can wiggle the seal housing on the shaft appreciably that is probably what is wrong.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95