75 spectra neovane pump
+ Reply to Thread
Results 1 to 4 of 4

Thread:
75 spectra neovane pump

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Posts
    2

    Default 75 spectra neovane pump

    dissasembled pump all looks good wont draw water 460 ford 3 bolt mount options for somthing else checked drive on cam ok water flows good with forced water 24 foot day crusier v drive sure would like to toss in trash can would like to go electric has down tube below transon not that familar with this assumeing this tube is force fed when boat is at speed checked hoses old butt look ok only thing i can come up with is suking air

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member SHADOW 21's Avatar
    Join Date
    Sep 2009
    Location
    GREENSBORO, NC
    Posts
    471

    Default

    Make sure you have the cover installed in the right position on the pump, I put mine on upside down and had the same problem.

  4. #3
    Junior Member
    Join Date
    Sep 2011
    Posts
    2

    Default neovane

    pump 105 2cover screws with in out arrows on top could be distorted has an oval shape new impeller new motor test fired with garden hose at the boat launch got hot quick tried to run it to force water in from down tube didnt work pulled pump thinking impeller would be trash nothing wrong must of had somthing there

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member Flat BROKE 612's Avatar
    Join Date
    Feb 2010
    Location
    Bumblefvck PEI
    Posts
    245

    Default

    Quote Originally Posted by dazed View Post
    dissasembled pump all looks good wont draw water 460 ford 3 bolt mount options for somthing else checked drive on cam ok water flows good with forced water 24 foot day crusier v drive sure would like to toss in trash can would like to go electric has down tube below transon not that familar with this assumeing this tube is force fed when boat is at speed checked hoses old butt look ok only thing i can come up with is suking air
    Do you live where there are freezing teperatures? If so the pump was prob not drained properly and the cover is pushed out losing seal with the impeller... measure with impeller thikness with calipers and the cover depth... carefully press back or buy a new one
    If you love someone set them free, If they come back with the cops...RUN!!!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95