weird spark plug, is this normal?? - Reply to Topic

Reply to Thread

Post a reply to the thread: weird spark plug, is this normal??

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 07-14-2010, 06:41 AM
    Mojave85
    Hey Sleek, sorry I missed you at the lake Tuesday. I had to go to the dentist for an appointment after work. Did you see any of the other guys up there or was it to windy for the flats? Did you decide to keep the boat?
  • 07-13-2010, 09:24 PM
    sleekcraft137
    Quote Originally Posted by 74glencoe View Post
    Be careful, they run the best right before they go BNAG!!!
    LL, yeah no kidding!! The "too good to be true" syndrome. I switched to a 750 carb when I changed the intake manifold. So I'm going to try the 650 again to see what happens. This plug and one other are new, the other plugs were a nice coffee color but seem to be lightening up. I guess its time to break out the timing light as well.
  • 07-13-2010, 09:19 PM
    74glencoe

    calm B4 storm

    Be careful, they run the best right before they go BNAG!!!
  • 07-13-2010, 09:09 PM
    sleekcraft137
    Quote Originally Posted by GT Jets View Post
    There is a metal rod going through the white part.......so i guess no?

    Unless it looked exactly like that when you put it in, that is a mechanical failure due to something hitting it, or concussion from detonation....

    Lean knock? Timing too advanced? Cross arching in cap?

    Good hunting...Anyone else have an idea?...I have to stop looking at it before my eyes start to bleed... LOL
    Motor ran great today........i know its running lean. I'm going to put the other carb back on and try again. I'll double check timing, its just weird b/c i didnt hear anything weird and the boat ran GREAT today.
  • 07-13-2010, 09:05 PM
    GT Jets
    Quote Originally Posted by sleekcraft137 View Post
    wouldnt it be loose??

    There is a metal rod going through the white part.......so i guess no?

    Unless it looked exactly like that when you put it in, that is a mechanical failure due to something hitting it, or concussion from detonation....

    Lean knock? Timing too advanced? Cross arching in cap?

    Good hunting...Anyone else have an idea?...I have to stop looking at it before my eyes start to bleed... LOL
  • 07-13-2010, 09:04 PM
    s2k1
    Cut the shell off so we can see the bottom of the insulator.
  • 07-13-2010, 09:00 PM
    sleekcraft137
    Quote Originally Posted by GT Jets View Post
    That plug looks broken from detonation....
    wouldnt it be loose??
  • 07-13-2010, 09:00 PM
    HammerDown
    Damn...my mother always told me my vision would go blurry if I kept playing with it
  • 07-13-2010, 08:55 PM
    GT Jets
    That plug looks broken from detonation....
  • 07-13-2010, 08:53 PM
    sleekcraft137

    weird spark plug, is this normal??

    So i had the boat out today for a few hours. I pulled the spark plugs to see how it was running(i changed the carb) as you can see its running lean.....no biggie. But do you see something that looks wrong with the plug?? notice the center. Is that normal?

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71