Oil Recommendations - Reply to Topic

Reply to Thread

Post a reply to the thread: Oil Recommendations

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 04-15-2008, 05:15 AM
    SmokinLowriderSS
    Quote Originally Posted by GAWnCA View Post
    I know one thing, this 20w50 is almost the same thing as running straight STP. So I'm going to try some 10w30 synthetic and see how that works out. My oil is at 80 psi with the 20-50.
    The synthetics are not nearly as thick cold.

    My 20-50 syn is likely thinner than 10w-40 dyno cold.

    My hot idle pressure is 23PSI

    My cold or hot running (WFO for miles and miles) pressure is 58PSI.
  • 04-14-2008, 09:48 PM
    Cas
    Quote Originally Posted by HawaiianJet View Post
    Thanks. I really hope so. I'm tired of taking all of these steps backwards. I wanna get the damn thing in the water by June. May ain't gonna happen, too much other stuff going on, plus every time I make any kind of progress I take about 5 steps back.
    Don't think you're the only one that's been there. Most people that have restored a boat to any degree has been through the same thing. Just take your time and ask questions (like you have), you will really be better off in the long run.
  • 04-14-2008, 09:42 PM
    HawaiianJet
    Quote Originally Posted by Cas View Post
    don't fret too much yet. Some sending units work with multiple gauges, maybe you'll get lucky and only have to find the cause of the erradic needle peg
    Thanks. I really hope so. I'm tired of taking all of these steps backwards. I wanna get the damn thing in the water by June. May ain't gonna happen, too much other stuff going on, plus every time I make any kind of progress I take about 5 steps back.
  • 04-14-2008, 09:38 PM
    Cas
    Quote Originally Posted by HawaiianJet View Post
    Really, well that sucks for me! Fuck!!!! I guess I'll have to look at what kind of gauges I have tomorrow, and look up sending units for them because I probably need the water temp one too because that one is the original one that came with the boat, and I ditched all of those gauges awhile ago. Thank you.
    don't fret too much yet. Some sending units work with multiple gauges, maybe you'll get lucky and only have to find the cause of the erradic needle peg
  • 04-14-2008, 09:27 PM
    HawaiianJet
    Quote Originally Posted by Cas View Post
    the sending unit needs to be matched to the gauge. For instance, a sending unit for a VDO gauge won't work with a Stewart Warner gauge.
    Really, well that sucks for me! Fuck!!!! I guess I'll have to look at what kind of gauges I have tomorrow, and look up sending units for them because I probably need the water temp one too because that one is the original one that came with the boat, and I ditched all of those gauges awhile ago. Thank you.
  • 04-14-2008, 09:13 PM
    Cas
    Quote Originally Posted by HawaiianJet View Post
    The oil sending unit is brand new and I'm pretty sure it is the right one, it is the same as the one that came with the boat, but does anybody have any pictures of theirs for a BBC.
    the sending unit needs to be matched to the gauge. For instance, a sending unit for a VDO gauge won't work with a Stewart Warner gauge.
  • 04-14-2008, 09:00 PM
    HawaiianJet
    Quote Originally Posted by jetboatperformance View Post
    Are you saying the guage "spikes when you turn the key on? , bad dash ground or wrong/shorted oil sender ,disconnect the sender wire ,insulate the wire and turn the key on ,post the results Tom
    Only when when I crank the engine, not when I turn the key to on position. It spikes and stays spiked. The oil sending unit is brand new and I'm pretty sure it is the right one, it is the same as the one that came with the boat, but does anybody have any pictures of theirs for a BBC. What do you mean by "insulate the wire"? Sorry won't be able to post the results for a couple of weeks, when I get the motor back in order. If it is still doing it when I get it all back together I will give you a call. It will probably still be doing it because it did it consistently from the very first time I tried to start the motor. Thanks Tom. HJ
  • 04-14-2008, 07:45 PM
    jetboatperformance
    Quote Originally Posted by HawaiianJet View Post
    Sorry about the thread jack. When I was trying to start my engine, the oil pressure gauge shoots straight up to maximum oil pressure on the gauge. What is the reason for this? And should I be worried about it? Don't know how it is going to act when the motor gets completely back together after being completely torn down, but that is what it was doing when we were trying to start it a couple of months ago. Can't remember what the max on my gauge is. Thanks. HJ

    Are you saying the guage "spikes when you turn the key on? , bad dash ground or wrong/shorted oil sender ,disconnect the sender wire ,insulate the wire and turn the key on ,post the results Tom
  • 04-14-2008, 07:13 PM
    HawaiianJet
    Sorry about the thread jack. When I was trying to start my engine, the oil pressure gauge shoots straight up to maximum oil pressure on the gauge. What is the reason for this? And should I be worried about it? Don't know how it is going to act when the motor gets completely back together after being completely torn down, but that is what it was doing when we were trying to start it a couple of months ago. Can't remember what the max on my gauge is. Thanks. HJ
  • 04-14-2008, 06:51 PM
    LakesOnly
    Quote Originally Posted by GAWnCA View Post
    My oil is at 80 psi with the 20-50.
    If your operating your mild engine build in typical jet boat fashion and have 80 psi with 20w-50 petroleum based motor oil, then i would say that you can try some 10w-40 and see what that does for your oil pressure. Generally, 80 psi is acceptable oil pressure and most people might tell you to stick with it. No argument there; frankly 70 psi is perfectly fine too in a mild build and this is why I think you might want to try the 10w-40.

    Also, things may change in a few months...beware that during hot peak summer days you just might find that twenty-hour-old 10w-40 petroleum based motor oil just isn't cutting it anymore and your oil pressure is lower than you may like to see. Adjust accordingly...be it stepping back up to 20w-50 or maybe synthetic 10w-40 (after a thorough break-in), etc.

    In short, for a mild rebuilder 460 with carb, intake, small cam, etc, I wouldn't want to see anything over the 80 psi that you have.

    I posted this reply on the other forum as well....

    LO
  • 04-14-2008, 06:33 PM
    Cas
    Quote Originally Posted by SmokinLowriderSS View Post
    I seem to get all kinds of stuff wrong, but I broke mine in on Syn, same Castrol I still run, with no problems.

    Maybe that's part of the reason the cam break in survived.

    that's why I put the question mark, I've heard lots of pros and cons on that subject.
  • 04-14-2008, 05:51 PM
    SmokinLowriderSS
    Quote Originally Posted by Cas View Post
    Being your engine is still new, I don't think you want to run a synthetic just yet?
    I seem to get all kinds of stuff wrong, but I broke mine in on Syn, same Castrol I still run, with no problems.

    Maybe that's part of the reason the cam break in survived.
  • 04-14-2008, 05:08 PM
    GAWnCA
    Well, I picked up 3 gals of Rotella 15W-40. So that's what's in the motor.
  • 04-14-2008, 04:48 PM
    jetboatperformance

    oil$

    We use and recommend Shell rotella for Cam breakin Then Torco , Solid stuff !!!
    http://www.torcoracingoils.com/
This thread has more than 14 replies. Click here to review the whole thread.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95