jetovator problem - Reply to Topic

Reply to Thread

Post a reply to the thread: jetovator problem

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 07-23-2011, 09:14 AM
    DuaneHTP
    Yes, Some of the early ones came without an O-Ring. We can machine it for an O-Ring and install one.
    Duane HTP
  • 07-22-2011, 09:03 PM
    sand dawg

    jetovator problem

    I bought a used jetovator from a fella on parts spam a few months ago. When I took it apart it didn't have a nozzle o ring in it and didn't even have a groove for one. I don't know what brand it is. every one i have ever seen had an o ring. I just figured it didn't need one. Any way I put the boat in for the first time today and it was blowing water out around that area'. Has any body had this problem and is there any way to fix the problem? Thanks for any help

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95