Droop Snoots - Reply to Topic

Reply to Thread

Post a reply to the thread: Droop Snoots

Your Message

 

Send Trackbacks to (Separate multiple URLs with spaces)

You may choose an icon for your message from this list

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 06-21-2008, 04:16 PM
    396_Ways_To_Spit
    Quote Originally Posted by Need4Speed77 View Post
    I have been told that there is too much hook in the hull and that if I want to get rid of the problem completely I need no more than 1/16" hook but that I also should not take out the hook completely to avoid getting pitched out. I don't know what boat yo have but this is what I have done to correct my problem. I am having the bottom done in two weeks and will update as to what the work accomplished.

    Manufacturers put hook in hulls to keep the porpoise down.
  • 06-21-2008, 12:54 PM
    Need4Speed77
    I had the same problem with my challenger. Although it is still porpoising at high speed it is not as severe anymore. I took the wedge out and a little better then reversed the wedge and got even better. I have been told that there is too much hook in the hull and that if I want to get rid of the problem completely I need no more than 1/16" hook but that I also should not take out the hook completely to avoid getting pitched out. I don't know what boat yo have but this is what I have done to correct my problem. I am having the bottom done in two weeks and will update as to what the work accomplished.
  • 06-21-2008, 07:25 AM
    slowboy
    Quote Originally Posted by carlsonauto View Post
    ON LAND OR SEA?????? ANYWAYS I WILL TEASE YOU REGARDLESS...... YOU KNOW I HAVE THE MAENS TO BEAT YOU I JUST CHOOSE NOT TO USE THAT ENGINE.

    HEY I BET IF YOU TAKE THAT HUGE ASS SHOE OFF OF THE BOTTOM OF YOUR BOAT IT WILL WORK BETTER


    SORRY I HAD TO

    The boat is a Make delta bottom boat, not the easiest to get to hook up. The boat does not have any hook.

    I was told by a shop to put a more agressive shoe on the boat, because my intake water pressure was only 10-15 psi full throttle. The shoe was 5/8 inch thick. I took the shoe off last night at the lake, took it for a ride, and the front was super light, problem gone. The agressive shoe was pulling the front down. On the way back to the landing with 4 people in the boat, we had 80 with a slight porpous.

    I am going to make a new shoe this morning, 1/4 inch thick, put the ride plate back on, and set it at 4 degrees up from the bottom of the hull. See if I can get it to handle a little better, tighten it up a little anyways.

    Then I will remove the wedges, at least we are getting somewhere now.

    Ryan
  • 06-20-2008, 11:24 PM
    RCB19
    Put the plate back on the boat and set it at 4*-5* in relation to keel. I am assuming that you have a V bottom??? Take the wedges out and bolt the droop back on the pump. Then take a straight edge and lay it up to the bottom of the ride plate and check the distance between the straight edge and the bottom of the droop where the pin holds the nozzle on. An acceptable measurement between the two should be 3/4 to 1/2 inch. Use different size wedges to raise or lower the droop to get it within this measurement. Typically you will wedge down but you need to see where you are at since every boat/droop is not quite the same. This should get you real close on your hardware set up. If you still have a bad hop you should take a look at the condition of the bottom of your boat. You didn't mention were you were running for the rest of your hardware. Shoe, loader etc.
  • 06-20-2008, 10:25 PM
    carlsonauto
    Quote Originally Posted by slowboy View Post
    When (IF) you beat me, then you can tease me

    ON LAND OR SEA?????? ANYWAYS I WILL TEASE YOU REGARDLESS...... YOU KNOW I HAVE THE MEANS TO BEAT YOU I JUST CHOOSE NOT TO USE THAT ENGINE.

    HEY I BET IF YOU TAKE THAT HUGE ASS SHOE OFF OF THE BOTTOM OF YOUR BOAT IT WILL WORK BETTER


    SORRY I HAD TO
  • 06-20-2008, 10:21 PM
    Mr. CBM
    Did you blueprint the bottom along with that pump setback? Seems like a possible hook issue. You will just be fighting yourself unless you fix it.
    hope that helps.
  • 06-20-2008, 04:08 PM
    Outlaw
    Quote Originally Posted by slowboy View Post


    I have a droop, and am wondering if it is causing my problem or not. Here is a picture of my pump. I took the ride plate off and the boat handled tons better, porpous completly went away.

    Thanks, Ryan

    Ditto on too much wedge. start with none and add them if needed.
    remember you just did a setback which gave those wedges more leverage
  • 06-20-2008, 02:35 PM
    slowboy
    Quote Originally Posted by IMPATIENT 1 View Post
    take all those wedges out, put the plate back on at 4degrees and start over, something is a miss here. got any at wot pics? remember to make 1 change at a time, or you'll create more issues than you fix

    I am going to try it as it is, I have been trying one change at a time, and it seems to be getting better. We will take some pictures tonight......... If my TRI-turbo friend ever gets done working on his.

    Then I will try what you recommended and go from there. Thanks again
  • 06-20-2008, 02:33 PM
    slowboy
    Quote Originally Posted by carlsonauto View Post
    it might be that someone needs to lay off the little debbie's and lighten the bow

    When (IF) you beat me, then you can tease me
  • 06-20-2008, 02:22 PM
    IMPATIENT 1
    Quote Originally Posted by slowboy View Post
    This boat did not act like this at all last year, All I did was set the pump back, and now it is slower. I had only a 6 degree wedge in it with the ride plate on. The boat would porpous badly at high speed, and almost throw you out of the boat. Changing the diverter all the way down would not help at all. The ride plate was not warped, and has braces on it to stop it from creating a hook. Seemed the higher I went with the ride plate, the better it got. Untill the ride plate was touching the pump. So I took it off, and it rides and handles tons better, but still way low in the front. What is causing the front to drop so badly?

    Thanks
    take all those wedges out, put the plate back on at 4degrees and start over, something is a miss here. got any at wot pics? remember to make 1 change at a time, or you'll create more issues than you fix
  • 06-20-2008, 02:15 PM
    carlsonauto
    it might be that someone needs to lay off the little debbie's and lighten the bow
  • 06-20-2008, 02:10 PM
    slowboy
    This boat did not act like this at all last year, All I did was set the pump back, and now it is slower. I had only a 6 degree wedge in it with the ride plate on. The boat would porpous badly at high speed, and almost throw you out of the boat. Changing the diverter all the way down would not help at all. The ride plate was not warped, and has braces on it to stop it from creating a hook. Seemed the higher I went with the ride plate, the better it got. Untill the ride plate was touching the pump. So I took it off, and it rides and handles tons better, but still way low in the front. What is causing the front to drop so badly?

    Thanks
  • 06-20-2008, 02:05 PM
    IMPATIENT 1
    Quote Originally Posted by slowboy View Post


    I have a droop, and am wondering if it is causing my problem or not. Here is a picture of my pump. I took the ride plate off and the boat handled tons better, porpous completly went away.

    Thanks, Ryan
    did ya try taking all those wedges out and just runnin the droop right to the bowl before pulling off the ride plate? you've got me wondering if your rideplate had too much or not enough angle and/or is was warped bad.
  • 06-20-2008, 02:01 PM
    slowboy


    I have a droop, and am wondering if it is causing my problem or not. Here is a picture of my pump. I took the ride plate off and the boat handled tons better, porpous completly went away.

    Thanks, Ryan
This thread has more than 14 replies. Click here to review the whole thread.

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95