alpha drive water pressure????
+ Reply to Thread
Results 1 to 5 of 5

Thread:
alpha drive water pressure????

  1. #1
    Senior Member obie's Avatar
    Join Date
    Feb 2009
    Posts
    738

    Default alpha drive water pressure????

    Question, i am running a 406 in front a alpha drive, can anyone tell me if there is water pressure present or if i have to put a gate valve on it. My machinest says i need around 25 lbs of water pressure in the block to avoid (hot spots) that will get air bubbles. Any thoughts, thanks.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	no quarter.jpg 
Views:	74 
Size:	91.3 KB 
ID:	149977  

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    Senior Member SoldHondaBoughtHondo's Avatar
    Join Date
    Oct 2009
    Location
    Lake Havasu az.
    Posts
    4,318
    "A liberal paradise would be a place where everybody has
    guaranteed employment, free comprehensive healthcare, free
    education, free food, free housing, free clothing, free
    utilities, and only law enforcement has guns. And believe it or
    not, such a place does, indeed, exist: It's called prison."

    Sheriff Joe Arpaio
    Maricopa County Sheriff's Office

  4. #3
    Junior Member
    Join Date
    Jan 2012
    Location
    massapequa,NY
    Posts
    25

    Default

    that drive will most likely make about 15-maybe 20 psi. that pump in that drive is a high pressure low volume pump. if you had a gen 2 drive they use a low pressure high volume pump. small impeller vane high pressure and low volume versus a large vane is high volume low pressure. what you could do is cut the hose that goes from the drive bellhousing to the transom assembly and plug off the one inside the boat. reason for that is you still need water to run through the drive for cooling the drive and it has a place to go. then install either a thru hull fitting with a ball valve or a transom mount water pickup and run a belt drive pump like used either on a closed cooling system or a bravo. i would not trust the alpha pump especially if you are running no circulating pump to supply a high performance engine. are you running a crossover and what t-stat hsg are you using and are you running a t-stat. all will play part in how you plumb your cooling system. if you go with the bravo system you will have all 1-1/4" hose so you will have plenty of volume of water to supply. the alpha drive will be 3/4" max from drive to the transom then out to 1-1/4" hose.

  5. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  6. #4
    Senior Member obie's Avatar
    Join Date
    Feb 2009
    Posts
    738

    Default temp

    Thanks for the reply, i have never ran a thermostat in this boat, and have never really had a problem.I just want to learn a bit about the drives as this is my first one. thanks for the info.

  7. #5
    Junior Member
    Join Date
    Jan 2012
    Location
    massapequa,NY
    Posts
    25

    Default

    i know that when i set up most race boats using bravo drives we just ran a single bravo seawater pump(belt driven) to a oil cooler then to a crossover(seawater circ pump eliminated) and then out at the top of the intake thermostat housing(no t-stat) to each header. you will have no water temp until your really in the throttle. we watched mostly the oil temp. not good to run hard with cold oil temp. running it this way on numerous boats and never saw a issue with anything like hot spots, broken valve springs etc. i know some will say different just telling you what we have been doing for years.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95