Performance Boats Forum banner

lean

  1. GN7 On the Dyno
    I was heading to the local sand bar and ran my Taylor SJ jet boat with a 505 maybe three or four miles and I noticed that the engine temp was moving up. It normally runs around 180 on the temp gauge and when it shut down it was at 220. It died on me while running about 3k RPMS and I had flames...
  2. Outboards
    OK, maybe not performance but who cares. I have a 9.8 I believe to be an 80 or 81. Unknown origin. I ran it one day, ran good, hard to start, poor water flow. Replaced impeller. Pretty good flow... still not steady stream, but will get full kit and redo. Replaced spark plugs and properly gapped...
  3. GN7 On the Dyno
    Hey guys i have twin 1050 Holly 3 circuit with 4.5 pv and 84 jets in all corners. 600" force feed innercooler, Whipple 8.3 with vacuum bypass valve on blower. I am in vacuum when the pop happens. I am getting a little lean pop out of carbs when cruising at about 2000-2500 rpms and pulling...
  4. GN7 On the Dyno
    Have my motor on the dyno and it was running rich. We put the air filters on and it went way lean 15:1 and climbing from a steady 11:1 before the filters/spark arrestors. blower motor 850 demon blower carbs. basicly we cut the tops off the spark arresters and now it about a two inch volocity...
  5. GN7 On the Dyno
    Hey Hallett, remember when we were talking about the fuel possibly pooling in the blower last year ???? Problem solved, I put 2 inch spacers on and installed 50 cc accelerater pumps over the winter and guess what , IT WORKED !!!!!!! Ran the boat tonight, ran flawlessly, not one lean pop, even...
  6. GN7 On the Dyno
    What do you think Well,,, here I go again.
  7. GN7 On the Dyno
    Need some info. Twin 750's vacuum secondarys, in line on a 468/ 671 /15 over/ 10 -12 lbs. boost @ 6500. Boat runs great, starts good, idles great, no hesitation upon acceleration, just explodes and runs great, plug color nice and dark tan. Now the problem. When I idle through a long no wake...
Top