Performance Boats Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
dissasembled pump all looks good wont draw water 460 ford 3 bolt mount options for somthing else checked drive on cam ok water flows good with forced water 24 foot day crusier v drive sure would like to toss in trash can would like to go electric has down tube below transon not that familar with this assumeing this tube is force fed when boat is at speed checked hoses old butt look ok only thing i can come up with is suking air
 

·
Registered
Joined
·
471 Posts
Make sure you have the cover installed in the right position on the pump, I put mine on upside down and had the same problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
neovane

pump 105 2cover screws with in out arrows on top could be distorted has an oval shape new impeller new motor test fired with garden hose at the boat launch got hot quick tried to run it to force water in from down tube didnt work pulled pump thinking impeller would be trash nothing wrong must of had somthing there
 

·
Registered
Joined
·
245 Posts
dissasembled pump all looks good wont draw water 460 ford 3 bolt mount options for somthing else checked drive on cam ok water flows good with forced water 24 foot day crusier v drive sure would like to toss in trash can would like to go electric has down tube below transon not that familar with this assumeing this tube is force fed when boat is at speed checked hoses old butt look ok only thing i can come up with is suking air
Do you live where there are freezing teperatures? If so the pump was prob not drained properly and the cover is pushed out losing seal with the impeller... measure with impeller thikness with calipers and the cover depth... carefully press back or buy a new one
 
1 - 4 of 4 Posts
Top