Performance Boats Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently purchased a "barn find " scarab 0 hrs, while going thru boat I removed the engine, when putting it back in the boat I had a lot of trouble aligning the drive,
I think the coupler was damaged as my 1st sea test the boat barely moved and the engine reved, I can't find any info on the part or where to buy it...help please
thanks Ron
 

·
Registered
Joined
·
161 Posts
I doubt the coupler is your problem, unless it got totally trashed somehow. More likely, you may have some debris in the jet pump.

If you are not sure what you are looking at, you might consider having someone who knows jets take a look at it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I doubt the coupler is your problem, unless it got totally trashed somehow. More likely, you may have some debris in the jet pump.

If you are not sure what you are looking at, you might consider having someone who knows jets take a look at it.
thank but I know nothing is in the jet, I haven't found any people including volvo techs that know about the pjx
I think the coupler was damaged installing the engine as I had a lot of problems lining it up
 

·
Registered
Joined
·
161 Posts
Not sure what coupler the Volva uses. I looked up the pump diagram and it looks pretty similar to a Berkeley JE pump. If the Volvo uses the same style coupler as a Berkeley, it would be highly unlikely that an alignment issue during installation would damage the coupler to the extent that it would not spin the pump.You would have had to seriously force the install to hurt it. Again, not sure what your coupler looks like...
 
1 - 4 of 4 Posts
Top