Performance Boats Forum banner

1 - 20 of 39 Posts

·
Administrator
Joined
·
16,875 Posts
Discussion Starter #1
OK heres the deal.........

Have tried to go out with 15 YO son in his Rogers Dragstar and tune the boat.

The engine is running fine.

Trying to tune in the pump/boat combo after a crude throw together get the entire thing going project.

If I am in the boat. It porposises like the biggest piece of shit on the water. To the point of unbearable to ride in.

When I get out, it runs and takes a set and goes like crazy.

What is the deal ???

We drilled the intake to take pressure readings. I can't ride in the boat to monitor them because the boat will not accept a rider.
Damn, Talk about a sensitive setup.

This is the damndest thing I have ever seen.
 

·
Registered
Joined
·
2,135 Posts
Best bet is to talk to people who have run that Rogers hull and get their setup info, and then make minor adjustments to suit your setup, weight/hull etc as even boats out of the same mold will respond differently at times.

You could get the GPS out and work on max speed, but your best bet is to try and make minor adjustments at the track and use the first season as a learning curve. Season two you can start pouring it on.

I assume you tried to trim the porpoise out?My dads boat has a nasty porpoise to it after a complete re-rig. Boat came with cav plates and no ride plate. Maiden voyage We left the cav plates off(ran out of time) and the rideplate too(forgot it). We are hoping the rideplate will fix the problem as the porpoise could not be trimmed. If it doesn't, we will know why the cav plates were on it to begin with...
 

·
Engine junkie
Joined
·
142 Posts
Sounds like the boat needs something to sit on, put a ride plate on it.

My old Avenger did the same thing, the ride plate made a world of difference along with adjusting the nozzle angle.
 

·
Administrator
Joined
·
16,875 Posts
Discussion Starter #5
Ron lets see the "set up" (pics and info) Intake , hardware , driveline etc etc ...
I'll see what I can do for pics this weekend Tom. I am going to speed coat the bottom.

We did build the boat to race but damn. Would be nice to ride in it lol

The boat handles fine with Info Jr in it by himnself.
 

·
just a ski boat with bark
Joined
·
2,811 Posts
I'll see what I can do for pics this weekend Tom. I am going to speed coat the bottom.

We did build the boat to race but damn. Would be nice to ride in it lol

The boat handles fine with Info Jr in it by himnself.
I'll say the boat seemed to run and set fine at Purcell, looks like your weight must throw the balance off. Since it looks to ride pretty flat with just your boy do you think it would need more wedge for you to ride in it?

Loren
 

·
Registered
Joined
·
4,677 Posts
from the pics i seen it was really wet looking,im gonna say the extra weight makes it worse causing it to bounce.

best of luck,glad to see the father and son team are having fun.:D
 

·
Registered
Joined
·
4,288 Posts
This is probably overly obvious ....but as far as watching the gauges maybe you could rig up a vid. camera to record them. I do that when I go out because it's impossible for me to drive wot and watch the a/f, oil pres, tach,pump pres, water pres,ect,ect....
 

·
Registered
Joined
·
7,464 Posts
I'll see what I can do for pics this weekend Tom. I am going to speed coat the bottom.

We did build the boat to race but damn. Would be nice to ride in it lol

The boat handles fine with Info Jr in it by himnself.

Ron After re reading this I'm tending to agree think with Tim and Loren here, when initialy working on the set up my Sanger Circle boat porposed uncontrollably with just a driver but was relatively tame with a passenger added. As you know Boats are very weight & weight distribution sensitive .
Clint, My freind who "campaigned" that same boat for years, went thru a multiude of set ups and changes ,intakes and harware etc, in its final seasons he consistanly ran 90s to triple digits and low numbers . when I spoke to him recently he said he'd share what he did if anyone needed help, call me and I'll try to put you in touch with him if you like
Tom
 

·
Registered
Joined
·
65 Posts
HB at r&d marine has set up many of these hulls that have run very hard with no porpus give him a call 714 993-2665

he will help you get it straight

jr
 

·
Administrator
Joined
·
16,875 Posts
Discussion Starter #15
Ron lets see the "set up" (pics and info) Intake , hardware , driveline etc etc ...
See anything from here? lol

We are going to speedcoat the bottom tomorrow. Will get some hardware pics then
 

Attachments

·
Resident Ford Nut
Joined
·
10,075 Posts

·
Administrator
Joined
·
16,875 Posts
Discussion Starter #18
OK Tom here a few pics. Showing where everything in the boat is located. Boat mfg recommended the engine be installed right where it is now. The pump shaft angle compared to the top of the stringer measures 6 degrees.

Held the straight edge on the keel to the ride plate It hit the shoe on the way back. . The back cut shoe prolly needs to go.

Let me know what to measure and I'll take a pic.

The bottom is a different color now. lol :)devil
 

Attachments

·
Administrator
Joined
·
16,875 Posts
Discussion Starter #19
Last one.

Yes it is ugly. This is the first time we had no regard for the way it looks. We are going to make it run then we will make it look nice.

And when we are finished pulling the transom plate off we will goop it up nice.

All of the hardware is as we bought the boat. Except for the ride plate and impeller. And the nozzle mod we did. And loader duh.
 

Attachments

1 - 20 of 39 Posts
Top