Performance Boats Forum banner

1 - 16 of 16 Posts

·
Members only
Joined
·
4,518 Posts
Discussion Starter #1
Have a problem breaking Teleflex diverter cables. I was bending the ends on them at the diverter connection when I would stand on the gas and the diverter was all the way down. So I changed the geometry and made the cable pull the diverter down. Last week at parker I stand on it for a brief moment & pulled the cable end right out of the housing. Needless to say I have to make sure the diverter is not down when using high rpms... Any one else experience this?

Problem #2 Using a Calgo steering on my ski boat and it seems to feel pretty good with the motor off. As soon as its running and I pull a skier out it is a bitch to turn & the cables become supper spongy. I have worked this thing over several times and talked to Grimes about it. But right now it sucks big time.
 

·
Registered
Joined
·
178 Posts
Have a problem breaking Teleflex diverter cables. I was bending the ends on them at the diverter connection when I would stand on the gas and the diverter was all the way down. So I changed the geometry and made the cable pull the diverter down. Last week at parker I stand on it for a brief moment & pulled the cable end right out of the housing. Needless to say I have to make sure the diverter is not down when using high rpms... Any one else experience this?

Problem #2 Using a Calgo steering on my ski boat and it seems to feel pretty good with the motor off. As soon as its running and I pull a skier out it is a bitch to turn & the cables become supper spongy. I have worked this thing over several times and talked to Grimes about it. But right now it sucks big time.
Maximus, Yes on the teleflex. Their load rating sucks in tension (pulls the crimp apart) In high loads I run two one on the push side one on the pull.

#2 you are not supposed to hook the ski rope to the looped ends on the nozzle:happy: But had the same issue with the Calgo on my sprint boat. I could get the slop out but the cable tension was so high the steeering effort sucked. I ended up building a belcrank system with two 43C cables. No slop no steering effort. I dont have any of the pictures but they were on the old HB site. Now use a product from SSS engineering in NZ. Rob At Bratt Jet has them here is a Pic I swiped showing it and their suction housing. If you wondered 1586 LBS as hung.
 

·
Premium Member
Joined
·
762 Posts
Hi Ben, I have the same problem/complaint todays cables just suck, lots of slop and poor quality. I have been looking at some other industrial cable manufactures to see if there is some thing better, that could possibly be retrofitted, will keep you posted. You also have me concerned about calgo steering, I have it in my boat but it is not finished, may have to look at different options. I like real responsive steering that has the right feel to it too. Thought calgo was supposed to do that , but???
 

·
Registered
Joined
·
3,736 Posts
Problem #2 Using a Calgo steering on my ski boat and it seems to feel pretty good with the motor off. As soon as its running and I pull a skier out it is a bitch to turn & the cables become supper spongy. I have worked this thing over several times and talked to Grimes about it. But right now it sucks big time.
Having same problem with my 21' with calgo. Identical scenario.....

My 19' daytona with calgo is no problems
 

·
Registered
Joined
·
988 Posts
Ive Had 2 Cables Take A Dump On Me. One Diverter Went To Hydraulic After That. And One Forward/Reverse Cable.
 

·
Members only
Joined
·
4,518 Posts
Discussion Starter #7
found some pics of the old rig up
View attachment 128086
Thats a nice set up but there is no room in my daycruiser for that. I have tried everything from making a wider tiller arm for the cable connections at the pump and no bueno. It is almost impossible for anybody to drive under a load. What pisses me off is I had a regular steering style cable but they don't make that model anymore and nothing fits under the open bow dash. Not sure why it would be different for a high power 19 footer vs a 21' ski boat?

As for the teleflex cable I may just have to switch over to a hydraulic set up. However I have always been fond of a manual multi position handle.
 

·
Administrator
Joined
·
11,648 Posts
We have switched to Glendinning cables for the most part. We were having significant problems with Teleflex off and on past couple years. So far so good no failures. And they're made 100% in the USA unlike many T's. Seems like all the cables coming out of Asia regardless of who's name is getting on them as the flavor of the day are a crap shoot at best.

Ben what did Grimes have to say about your Calgo issue? I've used them in the past and the worked good.
 

·
Registered
Joined
·
6,573 Posts
never had cable problems. but after running the thing for 2 years, the handle broke off at the root in the middle of vacation. went hydraulic, -in 1989-, and have never even thought of going back. have had/installed hydraulic in 3 of my boats, and never had a problem. just installed them iaw the instructions, and if i had any question, called tim.
 

·
Members only
Joined
·
4,518 Posts
Discussion Starter #12
never had cable problems. but after running the thing for 2 years, the handle broke off at the root in the middle of vacation. went hydraulic, -in 1989-, and have never even thought of going back. have had/installed hydraulic in 3 of my boats, and never had a problem. just installed them iaw the instructions, and if i had any question, called tim.
BP I actually used to have one on this thing. Problem is I didn't have a stop on it and hated trying to get the boat to set.:bangmyhead:
 

·
Members only
Joined
·
4,518 Posts
Discussion Starter #13
We have switched to Glendinning cables for the most part. We were having significant problems with Teleflex off and on past couple years. So far so good no failures. And they're made 100% in the USA unlike many T's. Seems like all the cables coming out of Asia regardless of who's name is getting on them as the flavor of the day are a crap shoot at best.

Ben what did Grimes have to say about your Calgo issue? I've used them in the past and the worked good.
Mike, Norm has been more than accomadating to this problem but honestly doesn't understand what the problem is. I don't believe there is anything wrong with the system. When the motor is off or just idling it steers fine. As soon as I start bringing up the RPM's, the nozzel gets hard to turn I guess and the cables start stretching & it feels like a bungee cord. I cannot figure out why this is happening. I have tried different nozzel angles checked the pocket and nylon ring etc... its the same results.:no:
 

·
Administrator
Joined
·
11,648 Posts
I actually just wanted to see if it was really you posting in the jet forum or if Scarlata had acquired your password.

It would be interesting to figure this out as I know there are many who don't have these issues running Calgo on a jet. What makes less sense still is you don't have it with other cable systems. I'm assuming your cable is wound tight in the drum.

No not your melon, the steering helm. :)coffee
 

·
Members only
Joined
·
4,518 Posts
Discussion Starter #15 (Edited)
I actually just wanted to see if it was really you posting in the jet forum or if Scarlata had acquired your password.

It would be interesting to figure this out as I know there are many who don't have these issues running Calgo on a jet. What makes less sense still is you don't have it with other cable systems. I'm assuming your cable is wound tight in the drum.

No not your melon, the steering helm. :)coffee

Yea its installed correctly. Lots of grease and no kinks in the cable. Like I said it works fine with no load against it. :sheep:

Now about these other cables... Do you think they are a large improvement over the teleflex style? When it comes time for the Schiada regatta I need to have this issue resolved, being the ammbassador of the jet community representing on that very special weekend:party1:
 

·
Members only
Joined
·
4,518 Posts
Discussion Starter #16
I actually just wanted to see if it was really you posting in the jet forum or if Scarlata had acquired your password.

It would be interesting to figure this out as I know there are many who don't have these issues running Calgo on a jet. What makes less sense still is you don't have it with other cable systems. I'm assuming your cable is wound tight in the drum.

No not your melon, the steering helm. :)coffee
Please don't address me using that duchebags name in the same post...:)coffee
 
1 - 16 of 16 Posts
Top