Performance Boats Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
981 Posts
Discussion Starter #1 (Edited)
Nevermind!!! i got it covered i found my caliper thats been missing for weeks lol... why was it sitting with the lawn mower???
 

·
Registered
Joined
·
981 Posts
Discussion Starter #3
ever install the ultimate wear ring??? Ive never built a pump and would like some guidance from installing the ring to properly shimming the impeller if need be. Some hands on guidance would be awesome, i learn easier from visual than i do reading it here on the forum... I got plenty of beer and im sure i could get some women over here for your please lol..


thanks for the offer on the caliper.
 

·
Angry American
Joined
·
3,103 Posts
I'm sure fleetimus has offered to help you on a couple of occasions. He's up in Colfax with a nice sized shop and lots of experience with the ultimate wear ring. You really should look him up.
 

·
Registered
Joined
·
981 Posts
Discussion Starter #5
I'm sure fleetimus has offered to help you on a couple of occasions. He's up in Colfax with a nice sized shop and lots of experience with the ultimate wear ring. You really should look him up.

Yea ive been to his pad... Nice place if i had a shop that big i wouldnt know what to do lol... That was my plan look him up and see if he could assist in the assembly.

thanks for the reply.
 

·
Angry American
Joined
·
3,103 Posts
Yea ive been to his pad... Nice place if i had a shop that big i wouldnt know what to do lol... That was my plan look him up and see if he could assist in the assembly.

thanks for the reply.
cool! I'm glad you hooked up with him now get that thing going so you can join us at Shasta or Tower Park! :)
 

·
Registered
Joined
·
981 Posts
Discussion Starter #7
cool! I'm glad you hooked up with him now get that thing going so you can join us at Shasta or Tower Park! :)
should be within the next 2 weeks at most.... motor on the stand just achin to be started up.. Just waiting on pump parts and a forward reverse cable... other than that... not much gotta work the bugs outa my tach it doesnt seem to wanna work and im not gonna try to break a motor in without it.
 

·
Angry American
Joined
·
3,103 Posts
should be within the next 2 weeks at most.... motor on the stand just achin to be started up.. Just waiting on pump parts and a forward reverse cable... other than that... not much gotta work the bugs outa my tach it doesnt seem to wanna work and im not gonna try to break a motor in without it.
I've got a tach that someone gave to me when when mine was acting up. I'll gladly pay it forward and send it your way so you can do your break in. After that, just put it on a shelf until someone else needs it.
It's nothing special but it works and it's even pretty accurate.
 

·
Registered
Joined
·
981 Posts
Discussion Starter #9
I've got a tach that someone gave to me when when mine was acting up. I'll gladly pay it forward and send it your way so you can do your break in. After that, just put it on a shelf until someone else needs it.
It's nothing special but it works and it's even pretty accurate.
Hey i appreciate that very much, ill be sure to pay it forward ive done a few things like this for other people but never had it done for me. Really appreciated. you live near sacramento???

Thanks again!
 
1 - 9 of 9 Posts
Top