Performance Boats Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,185 Posts
Discussion Starter #1
My turbos used to not go pass 7lbs. of boost now after making a hard pass the motor sounds different and the boost goes past 10lbs.! I let off quick and babied it back to the trailer. One of my hoses (the one that connects the carb. to the turbo) is very soft and a little crimped. There is no wierd smoke coming out or anything, just sounds a little off.
Any ideas??
Thanks in advance from a new turbo owner.
Nate
 

·
149 BGJ-Willis Power 540
Joined
·
538 Posts
Hey,

To find all the problems with the combustion chambers and rings, heads, valve seats, do a Leakdown and go from there.

The leakdown technician will advise you what is in disrepair.

Jet Boat Performance
(805) 466-4719Fax:

8410 # M El Camino Real
Atascadero, CA 93422
Email:



Willis
 

·
Some guy
Joined
·
3,615 Posts
after making a hard pass the motor sounds different and the boost goes past 10lbs
What do you mean by "sounds different"? How are the gauges when you run hard? What type of gas are you running? Feel free to PM if you want, I worked for Banks when those kits were popular (late 70's)
 

·
Registered
Joined
·
1,185 Posts
Discussion Starter #4
What do you mean by "sounds different"? How are the gauges when you run hard? What type of gas are you running? Feel free to PM if you want, I worked for Banks when those kits were popular (late 70's)
Haven't had time to dig into it but it sounds like its running with some loose spark plugs,wires or something.
Where can I get replacement hoses for this thing all the way around?
 

·
Registered
Joined
·
1,185 Posts
Discussion Starter #5
What do you mean by "sounds different"? How are the gauges when you run hard? What type of gas are you running? Feel free to PM if you want, I worked for Banks when those kits were popular (late 70's)
All the gauges check out. Oil: 60-80. Temp: 110-120*.
Running 91 octane. Never seen the boost go past 7lbs untill now. What could have changed to make that possible? A hose maybe?
 

·
Registered
Joined
·
1,164 Posts
Are the turbo's internaly wastegated? You could have one of the gates geting stuck closed slightly more than usual wich would cause an increase of boost.

Travis
 

·
Banned
Joined
·
4,599 Posts
I had that same thing happen to my Schiada with a blower. Turns out that I had broken a rocker. Check the valvetrain for starters as a drop in 1/8th of your cylinders will definately show an increase in boost, not to mention cause a "change in sound."

Haven't had time to dig into it but it sounds like its running with some loose spark plugs,wires or something.
So it sounds like it's got a dead hole or two??? check your valvetrain. ;)

Leakdown after that.
 
1 - 7 of 7 Posts
Top