Performance Boats Forum banner

1 - 20 of 67 Posts

·
AAARRRRRGGGGGGG!!!!!
Joined
·
288 Posts
Discussion Starter #1
I finally got my engine together after a year long build due to some unexpected extra costs. When I fired it up it ran like crap, wouldn't idle, dies after a few seconds and smelled like raw fuel, backfired... So I re checked the timing and the plug wires. My compcams cam came with the 4-7 swap. It still ran the same so I pulled the valve covers and watched the valves while I rotated it by hand and came up with 1,8,7,2,6,5,4,3. I checked a couple of times but came up with the same thing. I can't find this firing order anywhere on the web and was not told by comp cams about it. Does anyone here know anything about this? I have not re fired it because I want to figure this out first.

Anything would be helpful. Thanks, Matt.
 

·
Registered
Joined
·
5,180 Posts
The orignal order was 1-8-4-3-6-5-7-2. With the 4-7 swap it should be 1-8-7-3-6-5-4-2. Maybe the cam is not a swapped cam. Be sure the rotation on the cap is clock-wise
 

·
AAARRRRRGGGGGGG!!!!!
Joined
·
288 Posts
Discussion Starter #4
I didn't think of the dizzy rotation so I went out and checked and it is definately clockwise. Has anyone heard of a 2-3 swap. I don't know what cores are like but I figured this would have to be deliberately done. Not maliciously but intentional so I figure there must be a reason.

Matt.
 

·
AAARRRRRGGGGGGG!!!!!
Joined
·
288 Posts
Discussion Starter #7
I searched a couple of times and came up with nothing then I simplified my search and it is the firing order for the ls1.

So what damage did I do by running it with the wires crossed?

Matt.
 

·
Registered
Joined
·
5,180 Posts
I searched a couple of times and came up with nothing then I simplified my search and it is the firing order for the ls1.

So what damage did I do by running it with the wires crossed?

Matt.
Depends on how you adjusted valves.That is not good turning a motor over like that. I think you know what I meen. Crossed wires might pop a power valve in the carb if running a Holley
 

·
AAARRRRRGGGGGGG!!!!!
Joined
·
288 Posts
Discussion Starter #9
I knew when I asked if it would damage that there was no way to answer it with the info provided but on the off chance that some would tell me everything was going to be ok, that there was no way I could have done any damage, that it might even make the engine run better, I will keep asking.

Thanks for all the replies, I will cross my fingers and fire it up.

Matt.
 

·
Registered
Joined
·
1,418 Posts
There are cams that also swap 2-3, and the firing order is the same as an LS engine
 

·
AAARRRRRGGGGGGG!!!!!
Joined
·
288 Posts
Discussion Starter #14
Sounds like it should! My fuel feed leaves something to be desired so I couldn't check it outvery well but I think things are good.

Thanks, Matt.
 

·
Or Seth, either one
Joined
·
3,270 Posts
Sounds like it should! My fuel feed leaves something to be desired so I couldn't check it outvery well but I think things are good.

Thanks, Matt.
If I'm reading this right... You ran it with 1-8-7-2-6-5-4-3 firing order and it worked. If so, congrats!

If you spoke to the tech guy, I do not understand why he'd send you a custom grind with that firing order if you didn't specifically request it... Or clearly state the firing order in the paperwork received with the cam. Baffling! So... now you have a one-off odd ball engine. Make sure to leave plenty of notes for yourself, so you don't go through this again a couple years down the road. Especially if you sell it to someone else, make sure they know too. What a headache it would be to diagnose that shit! I'm impressed you pulled the valve covers to get the order. Wouldn't have thought of it myself.
 

·
Registered
Joined
·
1,622 Posts
I might be wrong, but, is that the "LS1" firing order ?
I believe Mercruiser uses this on the 525 hp and a couple of other ones we have one on the Dyno now with the same comp cam firing order but it might be just a 4-7 swap I'll check tommorrow. NO IT'S A 7-4 - 3-2 SWAP SAME AS YOURS
 

·
Registered
Joined
·
1,622 Posts
If I'm reading this right... You ran it with 1-8-7-2-6-5-4-3 firing order and it worked. If so, congrats!

If you spoke to the tech guy, I do not understand why he'd send you a custom grind with that firing order if you didn't specifically request it... Or clearly state the firing order in the paperwork received with the cam. Baffling! So... now you have a one-off odd ball engine. Make sure to leave plenty of notes for yourself, so you don't go through this again a couple years down the road. Especially if you sell it to someone else, make sure they know too. What a headache it would be to diagnose that shit! I'm impressed you pulled the valve covers to get the order. Wouldn't have thought of it myself.
don't have to pull the valve covers just pull the spark plugs and put a piece of paper in there and see the order they pop out when you tap the engine over... Easy
 

·
steelcomp was here
Joined
·
26,516 Posts
There are only a couple of cores for the BB Chev on the LS1 fioring order, and I don't think (not sure) you'll find one in the stock journal diameter. The ones I know of are 55mm or bigger. They're also real expensive.
 

·
Or Seth, either one
Joined
·
3,270 Posts
don't have to pull the valve covers just pull the spark plugs and put a piece of paper in there and see the order they pop out when you tap the engine over... Easy
Personally, I would have thought the cam would be what I thought I ordered. Wouldn't have thought to check the rocker arms for the firing order at all... or anything else. I love the little tricks I pick up around here from the guys who have "been there" and "done that", a little tissue in the spark plug holes would tell the tale too. Kinda like finding TDC on #1 with a finger on #1 spark plug hole... simply genius and simple... Thanks Jim!
 
1 - 20 of 67 Posts
Top