Performance Boats Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Does anyone know what the hose in the picture goes to or where it is supposed to connect on a Bravo 1 outdrive?



I was doing a routine checkup on the outdrive (fluid level, bellows, etc.) and found this broken connector in a loose hose. it is clamped and points down toward the lower unit, but I don't know what it's for or where it is supposed to connect to. Help would be appreciated, thanks.

1995 Ultimate Warlock 21' 454 Mag fuel injected, Bravo 1.
 

·
It's what we do
Joined
·
723 Posts
It's the speedo pressure hose. The yellow connector is broken off in the hose. It is a 1/4 turn fitting that goes into the top of the lower housing.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3 (Edited)
As far as I know, the speedo works off of a stainless pickup tube down under the stern.. I thought that the speedo worked by the incoming water pressure from that pickup tube. Are you saying that this rubber hose works in conjunction with that somehow?
 

·
Custom User Title
Joined
·
105 Posts
Someone may have put an external speedo pickup on your boat...

They do NOT work in conjuction with each other..

The one from your drive may not even be connected under the dash (if it's even run that far)

...You'll find out rather quickly once you connect it to the drive, they put out a surprising amount of water :cool:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
That makes sense now. I probably need to look up under the dash and try to determine if the 'stock' drive setup is still run that far, or if the rest of the hoses have been removed etc. I know that the PO put in a larger, water filled gauge, so he probably had the pickup replaced/bi-passed as well.
 

·
It's what we do
Joined
·
723 Posts
If you have a transom mounted pickup you do not need to hook up the original one. Just tie it up so it doesn't get caught up in anything.
 

·
Premium Member
Joined
·
1 Posts
My Bravo One looks similar and boy do I need help!

I see what you guys have said about the little hose part but mine looks like it has nothing inside. Also what is supposed to connect to the large hole just above that? It looks like it goes from out outdrive to the boat? A hose of some sort. I am a total newbe at this boat stuff. But a hole in a boat does not sound like a good idea. We were also getting our boat ready for the Summer and found these pieces missing/broken. Is this fix something that a total green boater can handle? We are the second owners of this boat.
Thank you so much for your assistance.
 
1 - 8 of 8 Posts
Top