Performance Boats Forum banner

1 - 4 of 4 Posts

·
Member
Joined
·
524 Posts
Discussion Starter #1
Does anyone happen to know if a video is out that shows how to install a comp cam 6200 series belt drive. Thanks
 

·
Registered
Joined
·
6,278 Posts

·
Registered
Joined
·
1,396 Posts
I"ve been running one for 5 or 6 years very happy with it....but I did have to relive a littel casting so it would mount flat..
 

·
Member
Joined
·
524 Posts
Discussion Starter #4 (Edited)
I run one and like it. What are you having trouble with? Its a pretty straight forward install if you have the instructions that came with it. If not go to this link and you be fine.
http://www.compcams.com/Technical/Instructions/Files/188.pdf
Thanks for the reply. I actually did not have trouble with it, I was curios if a video was out on it just see how someone else mounted it. The tensioner pulley was the difficult part and I was looking how other have done it. I checked in with comp cams and they informed me that they had a batch of short belts, if I have a short belt is yet to be determined, they are sending me a new one for which i'll send them back what I have and they will let me know. This was a mock set up so now it is time to remove the tensioner pulley, any ideas other than maybe something like a battery post puller. Steve

As not to leave this in suspense Comp cams packaged the belt drive I purchased with a short belt, lucky for me that the tech I talked with had knowledge that this could of happened. Long story short, with the right belt the installation was extremely easy, I can see why there has been no video available. Imagine what would of happened had I left the short one on, burn up the tensioner bearing, snap the belt, destroy the valves. Steve
 
1 - 4 of 4 Posts
Top