Performance Boats Forum banner
1 - 14 of 14 Posts

· Cantard
Joined
·
4,900 Posts
Discussion Starter · #5 ·
Thought you had that handled? Sounds like you did what I told you not to do.

Kids.:)sphss
Oh ya took your advice and all went smooth. Went and bought the finger tool and new magnet...got it back in the pump by turning it with a 1/4 socket on a long extension after about 45 minutes of wigglein and fishin.....all was good....big sigh of relief...happy again....life was good....till I noticed I was off a tooth...told myself do it right or don't do anything.... Didnt even get the dizzy out of the hole 2" when this disaster took place.
 

· Resident Ford Nut
Joined
·
10,033 Posts
That sucks... been there. I dropped a 1/2" socket down the dizzy hole because I didn't put a rag in the hole. Luckily I was able to fish it out with a magnet....lost over an hour.

S CP :|err
 

· steelcomp was here
Joined
·
11,830 Posts
Oh ya took your advice and all went smooth. Went and bought the finger tool and new magnet...got it back in the pump by turning it with a 1/4 socket on a long extension after about 45 minutes of wigglein and fishin.....all was good....big sigh of relief...happy again....life was good....till I noticed I was off a tooth...told myself do it right or don't do anything.... Didnt even get the dizzy out of the hole 2" when this disaster took place.
Oh, man....sorry about that. Thought you had it made.
When you're ready to learn to install a dizzy right the firsrt time, give me a call.:)grn :)hand
 

· Registered
Joined
·
4,674 Posts
i have a 302 in my 4x4 that when i took it apart to re-build it several years ago.i found 3 of the damn things in the oil pan:))eek:))i had ran the mill for 2 years before i decided it was weak and tore it apart.i climbed trees,rock cliffs ect.never once did it hurt anything.but still 3 :)Unsure:)Unsure.
 

· Cantard
Joined
·
4,900 Posts
Discussion Starter · #11 ·
When you're ready to learn to install a dizzy right the firsrt time, give me a call.:)grn :)hand
Its alive again. Dropped the pan installed the rod WITH THE PINCH CLIP. Ass backwards frigin motors.:D:|err

Quality is job #1 cause there still workin on it I guess.:p I will call you next time so I get it right the FIRSRT time.
 

· steelcomp was here
Joined
·
11,830 Posts
Its alive again. Dropped the pan installed the rod WITH THE PINCH CLIP. Ass backwards frigin motors.:D:|err

Quality is job #1 cause there still workin on it I guess.:p I will call you next time so I get it right the FIRSRT time.
Well at least you're looking out for the next guy. :)devil
Funny how important that stupid little clip is.:)sphss
:D :)hand
 

· Registered
Joined
·
4,038 Posts
Yeah, we know you're a closet Ford lover, so bag that one!:)devil
Besides, this isn't Ford's fault. It's an aftermarket pump drive shaft.
X 2....and even aftermarket pump drives have, or should have, the retainer on them....Don't blame Ford, blame the engine builder.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top