Performance Boats Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #5
There are some cracks in what I have. Near fasteners. I'm thinking it may be leaking there. Looks like a pia to remove?

Time well wasted
 

·
Registered
Joined
·
1,145 Posts
sea goin epoxy..... important, check the mfg. dates on the cans, use nothing over 90 days old. Top quality preparation is crucial.
 

·
Registered
Joined
·
7,464 Posts
There are some cracks in what I have. Near fasteners. I'm thinking it may be leaking there. Looks like a pia to remove?

Time well wasted
Level out the boat put enough water in the bilge to surround the intake casting and watch is if the water leaks are significant at all , If theres constant leak/drip your likely destined to remove the intake and reseal it as the bond between the hull and casting is separated (primetime to pull it and machine it for a shoe too) , if its very minor or fastener related you might get by with a bit of grinding and patching however if there is any oil present leaching thru the cracks your likely wasting time call if you need help removal looks formidable but is actually relatively simple , clean up of the casting and hull prior to reset is the real grunt work
 

·
Registered
Joined
·
1,145 Posts
curious why you would like to reset it, what do you hope to gain? Didn't you just have the motor mounts set up for your re-power?
 

·
Registered
Joined
·
212 Posts
Discussion Starter #10
I had thought there was an alignment issue but there's not, there is an issue with the "lining up" of the intake and front of the pump

Time well wasted
 
1 - 10 of 10 Posts
Top