Performance Boats Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
394 Posts
Discussion Starter #1
I mentioned on a previous post that I was running hot, and didn't know if that was an independent problem, or caused from my poly lock breaking and exhaust valve not opening....I say this because I've never had enough time to run it long enough, and actually drive it, to see what was up....

So I wanted to run this by you guys and see if I should change something.


So, I didn't set up the cooling system plumbing, but from what I can tell its pretty standard given by all the diagrams you guys show.

I have my water coming in to a ball valve, that is set to a pressure relief valve. (which has a bypass for itself) then it goes to the block junction, which goes up to the top 2 ports in the 4 port thermostat housing. The right port side goes to the bassett t-valve and goes to the headers, the starboard side goes to a ball valve, which is closed, then overboard.. The set up had a thermostat before, and it doesn't now. So does that sound right? Except I should open the ball valved a little now right, since I took out the thermostat?


HOWEVER: I just went down there to look at it again, and I discovered that the line out of the first ball valve coming fro the pump, that goes to the "t" that splits it to go to the block, has a kink in it...i'm thinking that was probably the problem...oops.



But please help me verify.

Thanks.
 

·
Member
Joined
·
186 Posts
Cooling system

I'm no expert on these cooling systems so take what I say with a grain of salt. From what I think I understand, the valve between the engine and the overboard dump should not be closed- it should be open most all of the way. If it was all the way closed the only way water could exit the block is through the headers. You would be getting too much water to the headers and you probably would run hot. You may have been getting reversion which could explain water in the oil.
 

·
The Man
Joined
·
1,788 Posts
That ball valve to the overboard flow of water should be open. You've got water coming in but no way for it to exit.
 

·
Registered
Joined
·
1,541 Posts
Diagram jet and v drive

Someone have a diagram for water lines for both boats? Including water to bassetts.
 

·
Registered
Joined
·
354 Posts
I dont have any valves in my cooling water set-up except for the bassett Tee, water comes from the pump to a Tee that feeds water inlets on both sides of the timing chain cover, then on the manifold water exits via a two port thermostat housing ( with out the thermostat installed ) one side goes to the baset tee, that feed the headers. the other side goes to the overboard dump. I never have overheating problems, runs a constant 150* at around 16psi
Bassett tee opens @ 2000 rpm and just forms steam in the exhaust.
 

·
The Good
Joined
·
483 Posts
I have three valves. One after the pump before the engine. just in case a line breaks it keeps water from flooding the bilge from the pump. the second between the thermo housing and overboard dump. it mostly open. This lets you create a little back pressure to tune the water temp in the block to your liking. the third is between the thermo housing and the header t valve. This lets you tune when your headers get water, also incase the ball valve in the Tee begins to stick open you can shut it off and keep from filling the headers up at idle.
I've never dealt with a 4 port thermo housing but doesn't water always enter the block at the water pump ports at the front of the block on either side of the timing cover? Are those ports plugged on your set up? If water is going both in and out at the thermo then it doesn't really "flow" through the block since it all winds up in the intake manifold?
 

·
Premium Member
Joined
·
7,464 Posts
Assuming I read right and you have eliminated your actual T stat pellet ?, the flow should now be (for headers) from the jet thru the bypass kit to a simple "T" below the Timing cover and then to the front of the engine(water pump ports) , if your going to ditch the T stat 4 port deaL , GUT the housing completely and plug two of the four ports , then simply loop the tops of t fittings on the front of the block W/P area) to each other , outlet water from your former 4 port deal (now a two port) now goes , one to your Basset T (then R&L to headers) and one to you OB dump , you can "pre valve" both these outlets if you like Call if you need help Tom 805 466 4719
 

·
Registered
Joined
·
394 Posts
Discussion Starter #9
Assuming I read right and you have eliminated your actual T stat pellet ?, the flow should now be (for headers) from the jet thru the bypass kit to a simple "T" below the Timing cover and then to the front of the engine(water pump ports) , if your going to ditch the T stat 4 port deaL , GUT the housing completely and plug two of the four ports , then simply loop the tops of t fittings on the front of the block W/P area) to each other , outlet water from your former 4 port deal (now a two port) now goes , one to your Basset T (then R&L to headers) and one to you OB dump , you can "pre valve" both these outlets if you like Call if you need help Tom 805 466 4719
would I be better off just putting the t-stat back in? I only took it out because most say they have no place in jet boats...however, as they say, if it ain't broke, don't fix it.


It's running hot with the unchanged t-stat setup, with no t-stat. Sounds like just popping it back in would be easiest...
 
1 - 9 of 9 Posts
Top