Performance Boats Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
i have a 79 glastron cvx23 wth a 466 ported dv3 heads big roller cam and 850 speed demon carb
having troulbes getting out of the hole acts like it wants to "cavitate" . i installed a loader that is supose to force water to the top side what else can i do to help solve this problem
 

·
Registered
Joined
·
1,379 Posts
Have you checked the condition of your wear ring and impeller? Could be loose and causing the slip. Also pretty heavy boat to move from a dead stop. The more power you add, the worse it could get. If everything is in good shape in the pump, I'd recommend a cavitation reducer impeller. They help those big boats a lot.
 

·
Registered
Joined
·
877 Posts
i have a 79 glastron cvx23 wth a 466 ported dv3 heads big roller cam and 850 speed demon carbhaving troulbes getting out of the hole acts like it wants to "cavitate" . i installed a loader that is supose to force water to the top side what else can i do to help solve this problem
Big Boat To Get Moving. Probably Needs A Pump Rebuild By A Reputible Shop. I Would Also Add A Set Of Bennet Adjutible Trim Tabs. I Have Used Them On Jet Boats Over 20 Ft. With Great results
 

·
Boat Nut
Joined
·
5,131 Posts
A good pump is key, Those boats are heavy, and they get heavier with age :shhh: When I have my 23 Sleek Jetboat, at a minimum tight pump with an A impeller. This was before the inducer was available in kit form, but impellers could be re-worked for better holes hot performance. As Duane mentioned, an inducer would help big time.
 

·
Registered
Joined
·
686 Posts
You mention no condition of the pump. Since DuaneHTP gave an answer give him a call. He knows a thing or two that could help you. I think his boat is about 23 ft. I can promise one thing, It's impressive to ride in. :happy:
 

·
I don't feel tardy
Joined
·
845 Posts
i have a 79 glastron cvx23 wth a 466 ported dv3 heads big roller cam and 850 speed demon carb
having troulbes getting out of the hole acts like it wants to "cavitate" . i installed a loader that is supose to force water to the top side what else can i do to help solve this problem


If the pump isn't up to it's potential, no matter what you throw at it (loader, horsepower) it will not help. Try going back to the stock rock grate and see what happens.
 

·
Registered
Joined
·
74 Posts
Make sure you're not sucking air anywhere, bad packing glands can suck air and cause lack of thrust.

Are you sure the F/R bucket is fully opening?

How does the front of the impeller look? If the leading edges are gouged, pitted, or flattened out it will reduce thrust.

Are there by chance rocks/debris stuck in the bowl? Only takes 5min or so to pull the E pump bowl and check.


Aren't the loaders supposed to help load the top of the pump at higher rpm/speeds? If so, it does you no good. I'd swap back to the standard rock grate as mentioned earlier.
 

·
Registered
Joined
·
112 Posts
i have a 79 glastron cvx23 wth a 466 ported dv3 heads big roller cam and 850 speed demon carb
having troulbes getting out of the hole acts like it wants to "cavitate" . i installed a loader that is supose to force water to the top side what else can i do to help solve this problem
My 2cts:
- Get rid of the loader. It won't help that big boat much/any on the top end, and will make the pump cavitate on the holeshot.
- As others mentioned, you probably need a pump rebuild and a new impeller. But check the packing to make sure it's not sucking air. Even if the clearances are "good", any cavitation "burn" marks on the existing impeller will only encourage cavitation. I went through this a couple of years ago on my 22' Dana with an AT-309 pump (9.25" impeller). Upgraded the horsepower just a bit (~50 HP) and I experienced holeshot cavitation that hadn't been there before.....

Good luck
 
1 - 8 of 8 Posts
Top