Performance Boats Forum banner

1 - 5 of 5 Posts

·
CAPTAIN KRYLON
Joined
·
101 Posts
Discussion Starter #1
Tried to put my pump together yesterday & ran in to a little problem.
I couldn't get the gap between the impeller & the wear ring even close to where it needs to be.
I usually try to get to .025. I am at like 1/8 of an inch.
The thrust bearing is pressed all the way to the shoulder on the shaft.
(Pulled the motor & checked it)
I bought this boat dissasembled. Is it possible that my impeller is for a shouldered wear ring? ( have never seen one)
I have a standard stainless wear ring in the pump.
Tried to get a pic but it wouldn't turn out.

Any Ideas?
 

·
Registered
Joined
·
7,464 Posts
Tried to put my pump together yesterday & ran in to a little problem.
I couldn't get the gap between the impeller & the wear ring even close to where it needs to be.
I usually try to get to .025. I am at like 1/8 of an inch.
The thrust bearing is pressed all the way to the shoulder on the shaft.
(Pulled the motor & checked it)
I bought this boat dissasembled. Is it possible that my impeller is for a shouldered wear ring? ( have never seen one)
I have a standard stainless wear ring in the pump.
Tried to get a pic but it wouldn't turn out.

Any Ideas?

There are multiple small issues you might encounter depending on if the shaft has been prior modified/machined and whos shaft it is , what/whos impeller, if the impeller skirt has been machined etc , it does sounds like standard clearace for a stock pump. Shims wont take care of the problem but there are multiple solutions depending on exactly how much space you actually need to take up get to .025 call me if I can help explain Tom 805 466 4719
 

·
CAPTAIN KRYLON
Joined
·
101 Posts
Discussion Starter #5
Impeller

Thanks guys for the input. That impeller is kinda tired. Worked out a good solution with Tom @ JBP
 
1 - 5 of 5 Posts
Top