Performance Boats Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
4,045 Posts
Discussion Starter #1
I got to test my new boat this weekend, YES! Boat ran good for stock 454 about 60 mph turning around 5800-5900 RPM! Well you know when I got back home out comes the stocker in goes the bigger motor! I know the increase in HP is going to probley need an impellor change I am running an A right now. The increase in HP will be around 660 double the 330 I pulled out! What would anyone suggest? I use the boat for fun not racing But, it will be tested!

WT
 

·
Registered
Joined
·
2,510 Posts
I've heard of people running the "A" impeller in their boats with 650 HP but not much over that. I just sent email to a buddy who builds Berk Jet pumps and asked him. I'll let you know for sure as soon as I hear back.
 

·
Registered
Joined
·
988 Posts
Congrats on the new boat. With 330 HP you probably dont have an A impeller spinning that many rpms. Your tach is off or you have a much smaller impeller or both.
 

·
Registered
Joined
·
4,677 Posts
Congrats on the new boat. With 330 HP you dont probably dont have an A impeller spinning that many rpms. Your tach is off or you have a much smaller impeller or both.
your dead on my friend,no way in hell will a stock style or even mild built motor turn a A impeller 5,800 plus,something is wrong my friend.

you should be turning around 4,600-4,800 maybe with a stone stock mill on a full A cut impeller;)
 

·
Glendale Arizona
Joined
·
2,368 Posts
your dead on my friend,no way in hell will a stock style or even mild built motor turn a A impeller 5,800 plus,something is wrong my friend.

you should be turning around 4,600-4,800 maybe with a stone stock mill on a full A cut impeller;)
Agreed. Speed doesn't seem to match the rpm for an A. Also agree with the 4600-4800 rpm. Possibly even 4400 depending on whether it's a Berk or Aggressor impeller.
 

·
Registered
Joined
·
4,045 Posts
Discussion Starter #6
Could be real loose LMAO! The tack reads correct at idle! I had an 79 SJ with a mild 460 and turned it 5800-6000 with an A impellor!
When I had the pump apart it had A stamped on it and no bad sign of bad wear! I did test with the stock bowl on the trailer ran up to 5700 Rpm then. Changed the bowl to a JG split and the RPMs are still high! The impeller could have been resized I don't know but I will check sizes!
 

·
Registered
Joined
·
4,288 Posts
Regardless it sounds like an impeller is in your future, unless your already running a stainless. I'll bet you end up with a "b" cut.
 

·
Registered
Joined
·
4,045 Posts
Discussion Starter #8
Hotbo That is why I was looking for Scott S. I was going to get him to take a look at pump and placement or set! Shoe, ride plate,cav. ETC. Thanks WT
 

·
jetboataholic
Joined
·
2,798 Posts

·
Registered
Joined
·
4,045 Posts
Discussion Starter #10
Regardless it sounds like an impeller is in your future, unless your already running a stainless. I'll bet you end up with a "b" cut.
Sounds that way Im Thinking I got too much clearence will check that too! Thanks WT
 

·
Registered
Joined
·
557 Posts

You might look at your impeller and compare the cut to this chart.
Your impeller may have started out life as an A but could have been cut down to a B, C, or even D.

Hope this helps,
Ken
 

·
No Sandbar To Far
Joined
·
3,276 Posts
What are the clearances on the wear ring?:)Unsure
 

·
About 500' AGL
Joined
·
2,470 Posts
Could be real loose LMAO! The tack reads correct at idle! I had an 79 SJ with a mild 460 and turned it 5800-6000 with an A impellor!
When I had the pump apart it had A stamped on it and no bad sign of bad wear! I did test with the stock bowl on the trailer ran up to 5700 Rpm then. Changed the bowl to a JG split and the RPMs are still high! The impeller could have been resized I don't know but I will check sizes!

A mild 460 wont turn an A to 5800-6000 rpm either. Something is off.:)bulb
 

·
Registered
Joined
·
4,677 Posts
A mild 460 wont turn an A to 5800-6000 rpm either. Something is off.:)bulb
you are very true with this statement;)

something is amiss.

heres what i turn in my sj with a mild maybe 500hp bbc.
i have b-cut agressor impeller.i turn 5500 no more sometimes less depending on the weather,ect.
5400-5500 is all i can do.
150 shot 6000 rpm maybe 6100 at best.my tach is correct.

my pump loads great.im wondering if you are not having loading problems??????????????????????????????
 

·
NW Spectraholic
Joined
·
588 Posts
I think I'd be checking the little 4-6-8 switch on the back of the tach. ;)
 

·
E-7 Sheepdog (ret)
Joined
·
6,834 Posts
I got to test my new boat this weekend, YES! Boat ran good for stock 454 about 60 mph turning around 5800-5900 RPM! Well you know when I got back home out comes the stocker in goes the bigger motor! I know the increase in HP is going to probley need an impellor change I am running an A right now. The increase in HP will be around 660 double the 330 I pulled out! What would anyone suggest? I use the boat for fun not racing But, it will be tested!

WT
As hotbo said, no way this side (or the other) of hades are you EVER going to spin an actual A with a 330HP 454 (or any other 330HP motor) to anything close to 6,000RPM.
Check that tach out, or rebuild the pump, and ditch the "D" impeller. :D

When my original tach went sour, it claimed I was spinning 5500RPM flat-footed too, and was just fine at 850 to 900 at idle. Motor was maxed at 4,800 for 25 years. Tach was off arround 15% full range.

As with Hotbo, my 454 was putting out 400HP clean, 500 on Nitrous, turning an Aggressor B (Berk A) 5000 RPM on the motor, 5,400RPM on the funny-gas.
 

·
Glendale Arizona
Joined
·
2,368 Posts
The tack reads correct at idle! I had an 79 SJ with a mild 460 and turned it 5800-6000 with an A impellor!
Barring problems with the tach, I wouldn't so much doubt the rpm due to whatever problems could be present. It's the rpm vs speed that's way off.

If the pump was healthy and you were actually turning an A impeller to 6000 rpm you should be running 90+ mph not 60 mph.

500 hp with an Aggressor AB and I'm only turning 5300-5400 rpm. Add a 150 shot and I'm still only turning 5600.
 

·
Sit N' Spin
Joined
·
1,423 Posts
Strongly agree. With an A impeller, stock wear ring and about .035" thrust clearance, and the diverter all the way down with two full tanks of fuel my boat would do about 62 and only be spinning 4500 RPM (that was not at full throttle either). Something is definitely off with the tach.

Just because a tach reads correct at idle doesn't mean it's not bad. My buddy had that same issue...correct at idle but would register about 5,200 RPM on a bone stock 454. Replaced the tach and his max RPM dropped to about 4200-4300ish.

If you know someone who can loan you a tach I'd swap it out.
 
1 - 20 of 32 Posts
Top