Performance Boats Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have a 12 wj and the shaft was seized up took it apart and the plastic wear ring was cracked and broke in a few places could this cause the shaft to seize? ? This is my first jet boat so im new to all this.
 

·
What the Hell is That?
Joined
·
1,633 Posts
We're you running and the pump seized? Or did you pull the bowl and wouldn't spin?

The impeller is keyed on the shaft. if a piece of the WR is obstructing the impeller it won't spin the shaft. If the impeller spins but shaft does not that's a bigger issue.

Now that I think about it, you have to pull the impeller to access the WR, so with no impeller on there the shaft doesn't turn? Is the motor still connected?


Sent from my iPhone using Tapatalk 2
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
No motor is out of the boat the bearing in frong of the shaft was also seized up the last guy neglected it the wear ring is plastic correct? ? I even put a pipe wrench on it and still wouldn't move when I pulled it the impeller waz at the very back of the pump looks like it was hitting the back part it broke the screws off that hold the plastic piece on
 

·
What the Hell is That?
Joined
·
1,633 Posts
Sounds like the thrust bearing let go, impeller/ shaft move forward, impeller starts eating the bowl/WR.

Pics would help.

Tear it all down and go over everything.

Give Tom at Jet Boat Performance a ring he can get you all set up.




Sent from my iPhone using Tapatalk 2
 

·
Premium Member
Joined
·
924 Posts
wj

Sounds like the thrust bearing let go, impeller/ shaft move forward, impeller starts eating the bowl/WR.

Pics would help.

Tear it all down and go over everything.

Give Tom at Jet Boat Performance a ring he can get you all set up.




Sent from my iPhone using Tapatalk 2
I have a 12wj used pump looks to be in good running cond $400.00 Jim 1818-890-1867
 
1 - 6 of 6 Posts
Top