Performance Boats Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
ok so this is the third time being towed in, shitty, so i hear a knocking noise from the pump and yes i disconected the driveshaft and the noise goes away so i know its the pump, and the noise increases with rpm, my other problem is i drive around and get everything warmed up shut it down and it wont restart, wait about 30 min when everything cools down and it fires up no problem, now i just replaced the entire fuel system including pump and filters, i checked and i have fuel and air but no spark. another thing is i mounted my coil directly to my head, is that getting to hot and causing it to stop working. idk so i have a horible knocking noise and a motor that wont run......and a river trip in two weeks help.........:no:
 

·
Registered
Joined
·
354 Posts
are you sure that your not getting water in the cylinders, water don't compress well! don't ask me how I know this. definitely move the coil, mount it off the engine if you can or on top of the manifold.
 

·
Registered
Joined
·
7,464 Posts
If you have isolated you noise to your jet by removing the drive line from the "mix' then you have answered your own question and need to address the jet issue , seperate from that if your having a "hot soak" problem with the ignition its likley a component (CD box ,coil, ballast or distributor trigger possibly even an ignition switch , if you were to describe in detail the rest of the ignition (type brand etc , it might aid in the diagnosis Tom
 

·
Registered
Joined
·
137 Posts
Discussion Starter #4
so i got the ich right after i wrote this i went and pulled the pump out im going to take it down to the shop tomarrow, as far as the no start, i have a msd 6a ignition, msd coil mounted to the head witch i will move,
 
1 - 4 of 4 Posts
Top