Performance Boats Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Have my motor on the dyno and it was running rich. We put the air filters on and it went way lean 15:1 and climbing from a steady 11:1 before the filters/spark arrestors. blower motor 850 demon blower carbs. basicly we cut the tops off the spark arresters and now it about a two inch volocity stack that goes to a flat piece of aluminum plate that the scoop mounts to and it is lean. if I take the scoop mount off it goes back to rich. Any ideas??????? :angry:
 

·
steelcomp was here
Joined
·
26,515 Posts
Have my motor on the dyno and it was running rich. We put the air filters on and it went way lean 15:1 and climbing from a steady 11:1 before the filters/spark arrestors. blower motor 850 demon blower carbs. basicly we cut the tops off the spark arresters and now it about a two inch volocity stack that goes to a flat piece of aluminum plate that the scoop mounts to and it is lean. if I take the scoop mount off it goes back to rich. Any ideas??????? :angry:
It's obviously interfearing with the air signal to the carb, probably over the airbleeds.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #4
Well the problem was the j bowl vents on the carbs. trimmed them like a street carb and lean condition gone. Thanks for the advise.
 

·
It's what we do
Joined
·
723 Posts
Or something is too close to the top of the bowl vents. You need at least 3/4 clearance over the bowl vents.
Bob's my hero :happy:
 
1 - 6 of 6 Posts
Top