Performance Boats Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4,677 Posts
Discussion Starter #1
okay my ole mans tx-19 505 according to his tach[autometer carbon fiber series] 2 years old.
turns his A/b agressor ss impeller 6500.sounds like it to me.the mill is zinging.
505 bbc.chris straub cam,brodix goodies,ect.

tx-19 medium lay-up.1979 model jbn.
pump dominator pump,agressor 11 vane bowl
short place droop,the new ones.4degree wedge
place divirder with red insert.



okay heres the deal.went out today and ran it,ole man finally wants to try to dial it in.

first of all.damn thing went to porposing half way thru the runs.5th hole in the divirder.never changed my handle position to try to see if it got any better above that,would have slowed me down anyway.imo

when i would let off after the run,wow the front of the boat would lay down pretty hard imo.(i know what hard is i have broke my steering off in my boat when i had a shoe hanging way below keel not fun)

the boat run 88mph on my handheld gps garmin.but the gps said weak signal,if that matters.


heres my thinking,checked ride plate earlier its 1 degree above keel,needs more.

i need to check shoe and if its below keel move to 1/16 above keel?

check loader ramps.

need to verify the tach.all i have is a ferra dial back timing light that has a tach in it.can i use it:)bulb

i know there is alot left on the table,just dont want to beat the shit outta his mill to get there.

so what do you guys think??im i thinking about right?or am i just full of hot air?

wondering if the 11 vane bowl is hurting it also?

88mph is not were it should be.period:|err
 

·
mo balls than $cents$
Joined
·
11,734 Posts
sounds like maybe the bowl is too far away from the impellor, you shouldn't be turnin that many with a aggressor, takes alot of hp to turn em.i would think a ab on that motor would/should turn around 5700-5800.

run the shoe level with the keel and the same with the loader, 4.0 degrees of ride plate , 5.0 nozzle angle(my old set-up basically when i wasn't racing)
 

·
Registered
Joined
·
4,045 Posts
Travis, you are right that speed is not TX speed! And the shut down sounds wicked! I think Tom probley has a good setup! And how much is the pump set back might make a difference! WT:)devil

Coby
 

·
Registered
Joined
·
4,677 Posts
Discussion Starter #4
hand hole is middle of transom.

im gonna set ride plate and measure the loader and shoe depth in the morning,to damn hot right know gotta go to the lake,lol!!!!later:)hand
 

·
mo balls than $cents$
Joined
·
11,734 Posts
hand hole is middle of transom.

im gonna set ride plate and measure the loader and shoe depth in the morning,to damn hot right know gotta go to the lake,lol!!!!later:)hand
you gotta 1/2 setback as ervin told me:D mine was in the same place trav, ya gotta give it alot of rideplate to get it air'd out, shoe will have to stay around keel, and i never could get away with less than keel on my loader, i cut up 3 loaders last summer finding what mine wanted:)sphss good thing is, i get too use 1 i ****ed up on this nordic:)devil:D
 

·
Registered
Joined
·
4,677 Posts
Discussion Starter #6
that's were Mr.youngblood set it.:)

im beginning to think my gps was getting a funky reading.

kept saying weak signal,around here we don't have to many good signals.gonna set the ride plate and check the shoe and loader and do this again:D


all i know is when i was on the floor there was blurry ass shit going on,like the trees and the water was a total blur :)devili think it is running alot faster than im thinking.
 
1 - 6 of 6 Posts
Top