Performance Boats Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 · (Edited)
Yeah, look for outboard throttle pedals.
Thanks, I emailed TH Marine to see if I can get a part number, I can't find anywhere online that specifys. Good to know they exist.

all you have to do it route the cable different.... if you want it to pull the linkage forward from the front of the engine then route it up behind the engine to push it forward... make sence?
Well I thought of that but the throttle body is on the end of the intake so there would be no place to mount the bracket plus the air filter would be in the way of the cable. I'm switching from drive by wire to cable throttle so I'll have to buy a pedal anyway.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #7 · (Edited)
If your looking for push pull @ the carb(s) the way you route the cable will fix that... works either way!
I see what you're saying but it's on a fuel injected setup with the throttle body on the back of the intake so I can only run the cable from the front. I think Ibhsbz told me what i needed to hear, as long as I know there is such a thing I'm good. I just need a part number.
 

·
Head Janitor
Joined
·
690 Posts
I guess you got your throttle figured out? Last I heard you thought you had but you hadn't tried it yet. The dbw is still giving me fits, I'm tired of messing with it.

Yes, I got mine figured out. I made a throttle bracket that holds the cable where I need it; and found out that my throttle pedal can push or pull depending on if you put the cable above or below the pivot point.

The bracket is *very* basic; but seems to do it's job. Haven't actually had it on the water yet (about 95% done with the EFI conversion) - so we'll see...
 

·
Registered
Joined
·
319 Posts
LS motor?

looking at the pic, it appears you turned your LS intake around backwards. thats what I did on the turbo LS jet boat I'm building. I just made a bracket to hold the cable so that it pushes the factory linkage on the intake. the cable comes up from under the motor to the bracket. seems fine but I haven't run it yet. no pics but maybe I'll get some.
 
1 - 12 of 12 Posts
Top