Performance Boats Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
Last trip out as I was getting up on plane, I hear some constant loud knocking coming from the rear of the boat, sounded like engine was letting go. Good oil pressure and temperature. Removed valve covers, cut oil filter, nothing...clean, plugs good as well. Still not saying I don't have an engine going south but thought I'd take a look at the drive line before pulling it.

My question is; how many bolts connect the u joint to the flexplate? There are three in a triangle pattern but I'm seeing a 4th hole with nothing in it. Wondering if that empty hole is for a universal set up or have I sheared a bolt?

Another question, if in fact this noise is coming from the u joint, would grease alone correct that? I have also greased the zerk at the pump/yoke.

No trash in the pump looking down the inspection hole however, I haven't had time to remove the grate to check for shaft play....that's job next.
 

Attachments

·
Registered
Joined
·
597 Posts
Crank dowel pin hole,,,,
 

·
Registered
Joined
·
4,318 Posts
U-joint companion flange has 4 bolts that attach it to adapter that bolts to the crank..if it only has 3, that is a problem. Bad u-joint will be loose in the caps or have tight spots as it is rotated.
 

·
Registered
Joined
·
187 Posts
Discussion Starter #5
Many thanks for the replies, flash light and mirror confirmed crank dowel pin hole. Drive line is fine, engine is terminal. Back to square one.....
 

·
Registered
Joined
·
597 Posts
Many thanks for the replies, flash light and mirror confirmed crank dowel pin hole. Drive line is fine, engine is terminal. Back to square one.....
What do I get,12 pack of IPA :)Unsure
 
1 - 7 of 7 Posts
Top